What's New in SolidWorks 2009
## Contents

### Notices
- ix

### Introduction
- xi
  - About This Book
  - Using This Book
  - Converting Files to SolidWorks 2009
  - Product Name Changes

### 1 Fundamentals
- 14
  - Callout Improvements
  - Converting Files to the Current Version of SolidWorks
  - Custom Properties
    - Customizing the Custom Properties Tab
    - Entering Properties
  - View Orientation Enhancements
  - Zoom Enhancements
  - Using the Magnifying Glass
  - Moving the CommandManager and PropertyManager
  - Improving User Interface Consistency

### 2 Materials and Appearances
- 21
  - Materials
    - Unified Materials Database and User Interface
    - Displaying the Material Dialog Box
    - Working With Materials
  - Appearances
    - Appearances Include Colors and Textures
    - Pop-up Toolbar
    - Rough Draft Appearance

### 3 Sketching
- 26
  - Move, Copy, and Rotate in 3D Sketches
  - Moving 3D Sketch Entities
  - Improved Functionality for Splines
  - Creating Equation Driven Curves
  - Ghost Images of Missing Sketch Entities
    - Displaying a Ghost Image of a Missing Sketch Entity
  - Numeric Sketch Input
    - Enabling Numeric Input
Contents

Specifying Numeric Input.......................................................................................................................... 29
Offsetting Infinite Lines.............................................................................................................................. 30
Repair Sketch Enhancements..................................................................................................................... 30
Resizing Sketches in Instant3D.................................................................................................................. 30
Slot Sketch Entity........................................................................................................................................ 31
Creating a Straight Slot............................................................................................................................. 31
Stretching Sketch Geometry....................................................................................................................... 32
Using Blocks in Sketches........................................................................................................................... 33
Saving a Sketch to a Block File.................................................................................................................. 33
Saving Sketches in the Design Library....................................................................................................... 33
Sketch Dimensions of Zero and Negative Values.................................................................................... 33
Reversing a Position Dimension............................................................................................................... 34

4 Features.................................................................................................................................................. 35
General.................................................................................................................................................... 35
Missing Reference Ghosting...................................................................................................................... 35
Boundary Features.................................................................................................................................... 37
Extrudes and Slots..................................................................................................................................... 38
Fastening Features.................................................................................................................................... 38
Freeform Features..................................................................................................................................... 38
Instant3D.................................................................................................................................................. 39
Instant3D in Assemblies............................................................................................................................. 39
Editing Sketches in Instant3D.................................................................................................................... 41
Instant3D Live Section Planes................................................................................................................... 42
Instant3D and Mirrors or Patterns............................................................................................................. 44
Instant3D and Move Face Features........................................................................................................... 44
Instant3D Weldments................................................................................................................................. 45
Lip and Groove Fastening Features......................................................................................................... 47
Ribs............................................................................................................................................................ 48
Solid Sweep Cuts........................................................................................................................................ 48

5 Parts....................................................................................................................................................... 51
Dual Dimensions for Measurement Results.............................................................................................. 51
Dimensions in Mirrored and Derived Parts.............................................................................................. 52
Custom and Default File Properties in Equations................................................................................... 53
Changing Parts Display Characteristics...................................................................................................... 53
Reattach Derived Parts.............................................................................................................................. 54
Reattaching Existing Derived Parts.......................................................................................................... 55
Reattaching Parts When You Change Trim Tools.................................................................................... 55
Custom Properties Assigned to Parts....................................................................................................... 56
Sensors....................................................................................................................................................... 56
Mold Design............................................................................................................................................. 56
Analysis Tools.......................................................................................................................................... 56
Sheet Metal................................................................................................................................................ 57
Convert to Sheet Metal............................................................................................................................... 57
Contents

8 Drawings and Detailing ................................................................. 85
  Customized Drafting Standards ............................................. 85
  Overall Drafting Standards and Base Detail Standards ........ 86
  Document Layer Defaults .................................................... 87
  Custom Line Thickness and Style ....................................... 87
  Detailing Previews for Document Properties ..................... 88
  Bills of Materials (BOMs) ...................................................... 88
  Copying Assembly BOMs into Referenced Drawings .......... 88
  Restructuring BOMs .......................................................... 89
  Detailed Weldment Cut Lists in BOMs ............................... 90
  Item Numbering ................................................................. 90
  Detail Positioning ............................................................... 91
  Positioning Notes .............................................................. 91
  Attaching Dimension Extension Lines ............................... 92
  Jogging Extension Lines .................................................... 92
  Dimension Leader Control for Same-sized Features ......... 92
  Multiple Jogs for Dimensions and Callouts ..................... 94
  Print Options for Drawings ................................................. 94
    Printing Drawings from Zoomed Selections .................... 94
    Custom Line Thickness for Print Settings ..................... 94
  Title Blocks in Drawing Sheets ....................................... 95
    Title Block Management ............................................... 95
  Favorites are Renamed to Style .................................... 97
  Format Painter ................................................................. 97
    Using Format Painter .................................................... 97
  Detailing for Sketch Slots ............................................... 98
  General ................................................................. 99
    Cancelling Long Operations for Drawings .................. 99
    Exporting Tables to Excel ............................................ 99
    Opening Multi-sheet Drawings in Quick View ............... 100
    Document Properties Options Reorganization ............. 100
    Lightweight Assembly Drawings ................................. 100

9 Tolerancing ............................................................................. 101
  Intersect Line Features .................................................. 101
  ISO Standards Support .................................................. 102
  Orientation Constraints ............................................... 105
  Redundant Dimensions ................................................ 106
  Tangency Constraints .................................................... 107

10 SolidWorks Simulation ....................................................... 108
Contents

Product Name Changes................................................................. 108
Simulation Workflow........................................................................ 109
  User Interface........................................................................ 109
  Managing Simulation Studies.................................................. 111
  General.................................................................................. 112
Simulation Studies........................................................................ 112
  Simulation Advisor................................................................. 112
  Sensors.................................................................................. 112
  Material.................................................................................. 113
  (Premium) Composite Shells.................................................. 114
  Beams................................................................................... 118
  (Professional) Thermal Studies............................................. 119
  (Professional) Geometry from Deformed Shape...................... 119
  Stress/Deformation................................................................. 120
  (Premium) Remote Load/Mass for Linear Dynamic Studies...... 120
Assemblies................................................................................... 121
  Enhancements to Assembly Modeling..................................... 121
  Sheet Metal Parts................................................................. 122
  Study Tree Enhancements..................................................... 122
Connectors................................................................................... 122
  Factor of Safety for Connectors........................................... 122
  Bolt Connectors.................................................................. 124
  Pin Connectors.................................................................... 125
  Bearing Connectors.............................................................. 125
Mesh........................................................................................... 126
  Mesh Selection................................................................... 126
  Curvature-based Mesher....................................................... 127
  Mesh Control....................................................................... 128
  Simplify Model for Meshing.................................................. 128
Contact and Bonding.................................................................... 128
  Contact for Nonlinear Studies............................................. 128
  No Penetration and Shrink Fit Contact................................. 128
  Bonding............................................................................... 129
Result Viewing............................................................................. 130
  Factor of Safety Check....................................................... 130
  Results............................................................................... 131
  Compare Results................................................................. 132

11 Other Functionality..................................................................... 133
Installation.................................................................................. 133
  Administrative Image Configuration and Deployment........... 133
  Installation Manager Support for Manually Downloading Files 134
  Installation Error Message Links.......................................... 134
Application Programming Interface............................................ 134
DWGeditor .................................................................................. 135
© 1995-2008, Dassault Systèmes
Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company.
300 Baker Avenue, Concord, Mass. 01742 USA. All Rights Reserved.

Patents

U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,603,486; 6,611,725; 6,844,877; 6,898,560;
6,906,712; 7,079,990; 7,184,044; and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643).
U.S. and foreign patents pending.

The information and the software discussed in this document are subject to change without
notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronic or
mechanical, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or
copied only in accordance with the terms of this license. All warranties given by DS SolidWorks
as to the software and documentation are set forth in the SolidWorks Corporation License and
Subscription Service Agreement, and nothing stated in, or implied by, this document or its
contents shall be considered or deemed a modification or amendment of such warranties.

Trademarks and Copyrights

SolidWorks, 3D PartStream.NET, 3D ContentCentral, DWGeditor, PDMWorks, eDrawings, and
the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered
trademark of DS SolidWorks.

Enterprise PDM and SolidWorks 2009 are product names of DS SolidWorks.

FloXpress, DWGseries, DWGgateway, Feature Palette, PhotoWorks, TolAnalyst, and
XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Software Solutions Co. Ltd.

Other brand or product names are trademarks or registered trademarks of their respective
holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

U.S. Government Restricted Rights. Use, duplication, or disclosure by the government is subject
to restrictions as set forth in FAR 52.227-19 (Commercial Computer Software - Restricted
Rights), DFARS 227.7202 (Commercial Computer Software and Commercial Computer Software
Documentation), and in the license agreement, as applicable.

Contractor/Manufacturer:

Dassault Systèmes SolidWorks Corporation, 300 Baker Avenue, Concord, Massachusetts 01742
USA.

Portions of this software © 1990-2008 Siemens Product Lifecycle Management Software III
(GB) Ltd.

© 1998-2008 Geometric Software Solutions Co. Ltd.,
© 1986-2008 mental images GmbH & Co. KG,
Introduction

This chapter includes the following topics:

- About This Book
- Using This Book
- Converting Files to SolidWorks 2009
- Product Name Changes

About This Book

This book highlights and helps you learn the new functionality in the SolidWorks® 2009 software. It introduces concepts and provides step-by-step examples for many of the new functions.

This book does not cover all details of the new functions in this software release. For complete coverage, refer to the SolidWorks Help.

Intended Audience

This book is for experienced users of the SolidWorks software and assumes that you have a good working knowledge of an earlier release. If you are new to the software, you should complete the SolidWorks Tutorials lessons and then contact your reseller for information about SolidWorks training classes.

Additional Resources

Interactive What’s New is another source of information about new functionality. Click 🔄 next to new menu items and the title of new and changed PropertyManagers to read what is new about the command. A help topic appears with the text from this manual.

Late Changes

This book might not include all of the enhancements in the SolidWorks 2009 software. Check SolidWorks Release Notes for late changes.

Using This Book

Example Files

Use this book with the example part, assembly, and drawing files provided. The example files are in the <install_dir>\samples\whatsnew folder.
Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>User interface</strong></td>
<td>Refers to any SolidWorks user interface item.</td>
</tr>
<tr>
<td><strong>User input</strong></td>
<td>Refers to text you enter.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Refers to books and other documents, or emphasizes text. Also indicates variables in paths, such as <code>&lt;install_dir&gt;</code> and <code>&lt;language&gt;</code>.</td>
</tr>
</tbody>
</table>

Tip. Provides beneficial information.

Note. Provides information that supplements a main point.

Warning. Indicates a situation in which data could be lost.

Indicates a reference to *SolidWorks Help*.

Converting Files to SolidWorks 2009

Opening a SolidWorks document from an earlier release might take extra time. After the file is opened and saved, subsequent opening time returns to normal.

You can use the SolidWorks Task Scheduler to convert multiple files from an earlier version to the SolidWorks 2009 format. To access the Task Scheduler, click Windows **Start**, then **All Programs > SolidWorks 2009 > SolidWorks Tools > SolidWorks Task Scheduler**.

In the Task Scheduler:

- Click **Convert Files** and specify the files or folders to convert. See File Conversion on page 151 for more information about this new command.
- For files in a SolidWorks Workgroup PDM vault, use **Convert Workgroup PDM Files** (previously called **Update PDMWorks Workgroup Files**).

For files in a SolidWorks Enterprise PDM vault, use the utility provided with Enterprise PDM.

⚠️ After you convert files to SolidWorks 2009, you cannot open them in older SolidWorks versions.

Product Name Changes

The following product names have changed in SolidWorks 2009:
<table>
<thead>
<tr>
<th>Current Name</th>
<th>New Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>SolidWorks 3D MCAD Software</td>
<td>SolidWorks® Standard</td>
</tr>
<tr>
<td>SolidWorks Office Premium</td>
<td>SolidWorks® Premium</td>
</tr>
<tr>
<td>SolidWorks Office Professional</td>
<td>SolidWorks® Professional</td>
</tr>
<tr>
<td>PDMWorks® Enterprise</td>
<td>SolidWorks® Enterprise PDM</td>
</tr>
<tr>
<td>PDMWorks Workgroup</td>
<td>SolidWorks® Workgroup PDM</td>
</tr>
<tr>
<td>COSMOS</td>
<td>SolidWorks® Simulation</td>
</tr>
<tr>
<td>COSMOS FloXpress</td>
<td>SolidWorks® FloXpress™</td>
</tr>
<tr>
<td>COSMOSFloWorks</td>
<td>SolidWorks® Flow Simulation</td>
</tr>
<tr>
<td>COSMOSMotion™</td>
<td>SolidWorks® Motion</td>
</tr>
<tr>
<td>COSMOSM</td>
<td>SolidWorks® Simulation Premium</td>
</tr>
<tr>
<td>COSMOSWorks Advanced Professional</td>
<td>SolidWorks® Simulation Premium</td>
</tr>
<tr>
<td>COSMOSWorks Designer</td>
<td>SolidWorks® Simulation</td>
</tr>
<tr>
<td>COSMOSWorks Professional</td>
<td>SolidWorks® Simulation Professional</td>
</tr>
<tr>
<td>COSMOSXpress</td>
<td>SolidWorks® SimulationXpress</td>
</tr>
<tr>
<td>DWGseries</td>
<td>SolidWorks® DWGseries™</td>
</tr>
<tr>
<td>eDrawings</td>
<td>SolidWorks® eDrawings®</td>
</tr>
<tr>
<td>eDrawings Professional</td>
<td>SolidWorks® eDrawings® Professional</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
This chapter includes the following topics:

- Callout Improvements
- Converting Files to the Current Version of SolidWorks
- Custom Properties
- View Orientation Enhancements
- Zoom Enhancements
- Using the Magnifying Glass
- Moving the CommandManager and PropertyManager
- Improving User Interface Consistency

Callout Improvements

Feature callouts have been enhanced for better appearance and interaction.

For example:

You can select callout choices from a list.

Callout buttons are consistent with other SolidWorks buttons.

The appearance of text for mate and TolAnalyst callouts is improved.

Converting Files to the Current Version of SolidWorks

SolidWorks Task Scheduler replaces the Conversion Wizard as the utility for performing file conversions from earlier SolidWorks releases. SolidWorks Task Scheduler converts files in the network file system or in SolidWorks Workgroup PDM vaults. SolidWorks Enterprise PDM file conversion utilities are not in the Task Scheduler.

The new Convert Files task performs the conversion. It checks for dependencies automatically and converts referenced parts before it attempts to convert assemblies.

To access the Task Scheduler, click Windows Start, then All Programs > SolidWorks 2009 > SolidWorks Tools > SolidWorks Task Scheduler. In the Task Scheduler, click Convert Files.

💡 Until a file is converted to the current version of SolidWorks and saved, the File > Save command contains a warning icon, indicating that the file will be converted when saved.
Custom Properties

A new interface is available for entering custom and configuration-specific properties into SolidWorks files.

You enter the properties on the new Custom Properties tab in the Task Pane. In assemblies, you can assign properties to multiple parts at the same time.

You customize the Custom Properties tab using the new Property Tab Builder, which is a stand-alone utility. You can create different versions of the tab for parts, assemblies, and drawings.

You can still enter properties on the Custom and Configuration Specific tabs in the Summary Information dialog box.

Customizing the Custom Properties Tab

💡 In companies with multiple SolidWorks users, typically one person, such as the lead user or administrator, creates the customized tabs for everyone to use.

To customize the tab:

1. From the Windows Start menu, click All Programs > SolidWorks 2009 > SolidWorks 2009 > SolidWorks Tools > Property Tab Builder.
   The Property Tab Builder opens. The center pane contains the form you are creating for the tab. You drag items such as text boxes and radio buttons from the palette on the left, and set values and controls for those items in the pane on the right.

2. Under Control Attributes:
   a) For Message, type Enter custom properties for parts here. A message box containing the text you typed appears in the center pane.
   b) For Type, select Part.


4. Under Control Attributes, for Caption, type BOM Information. The label on the group box in the center pane changes to BOM Information.

5. Drag a Textbox from the palette into the BOM Information group box. The attributes for a text box appear in the right pane.

6. Under Control Attributes, for Caption, type Description. The label on the text box in the center pane changes to Description.

7. Under Custom Property Attributes:
   a) For Name, select Description from the drop-down list. Name controls the name of the resulting custom property. You can select from the drop-down list or type a new name. The drop-down list contains all names from the existing properties.txt file.
   b) For Type, select Text.
   c) Leave Value blank.
   d) For Configurations, select Show on Custom Tab.
8. Drag a **List** from the palette into the **BOM Information** group box and position it below the **Description** box.

9. Under **Control Attributes**, for **Caption**, type **Material**.

10. Under **Custom Property Attributes**:
    a) For **Name**, select **Material**.
    b) For **Type**, select **List**.
    c) For **Value**, type these three materials, each on a separate line: **Copper**, **Brass**, and **Zinc**.
    d) For **Configurations**, select **Show on Custom Tab**.

11. Click **Save** and save the tab in the location where you store your existing **properties.txt** file. Use the default name (**template.prtprp**).

   To find the location of your existing **properties.txt** file, in SolidWorks, click **Tools > Options > File Locations**. Under **Show folders for**, select **Custom Properties Files**. The path appears under **Folders**.

12. Close **Property Tab Builder**.

   To share the customized tab, store it on a network drive that is accessible by all SolidWorks users on the design team. Then have the users set their file location for **Custom Properties Files** to the folder where you saved the tab.

### Entering Properties

To enter properties:

1. Open **Assemblies\base plate.sldprt**.

2. On the Task Pane, click the **Custom Properties** tab. The customized tab you created appears in the Task Pane.

3. For **Description**, type **Base Plate**.

4. For **Material**, select **Brass**. The data is saved on the **Custom** tab of the **Summary Information** dialog box when you save the part file.

### View Orientation Enhancements

You now can use the reference triad at the bottom left of the graphics area to change the view orientation.
Select an axis
Select an axis that is normal to the screen
Shift + select
Ctrl + Shift + select
Alt + select
Ctrl + Alt + select
See the view normal to the screen.
Change the view direction 180 degrees.
Rotate 90 degrees about the axis.
Rotate 90 degrees in the opposite direction.
Rotate about the axis by the Arrow keys increment specified in Tools > Options > System Options > View.
Rotate in the opposite direction.

You now can resize the View Orientation dialog box.

Zoom Enhancements

- To zoom to fit, double-middle-click in the graphics area.
- To disable the automatic fitting of a model to the graphics area when switching to a standard view, clear the Zoom to fit when changing to standard views option specified in Options > System Options > View.

Using the Magnifying Glass

Use the magnifying glass to inspect a model and make selections without changing the overall view. These actions facilitate selection of entities for operations such as creating mates.

To use the magnifying glass to help select entities in an assembly:

1. Open Assemblies\food_processor.sldasm.
2. Hover over the exposed gear and press G.
   The magnifying glass opens.
To customize the keyboard shortcut used to start the magnifying glass, click **Tools > Customize**. On the **Keyboard** tab, search for **Magnifying Glass** and enter the shortcut key.

3. Move the pointer around the model. The magnifying glass moves, maintaining the same degree of zoom. The model remains stationary.

   To gain improved control over movement, **Ctrl** + middle-drag to pan with the magnifying glass.

4. Scroll the mouse wheel to zoom in. The model remains stationary while the magnifying glass area zooms in.

5. Press **Alt** and scroll the mouse wheel to display a section view parallel to the screen.
6. **Ctrl** + select entities.

   The magnifying glass closes if you select an entity without pressing **Ctrl**.

7. Complete your action, such as creating a mate.
8. Click to close the magnifying glass. You can also press **G** or **Esc**.

### Moving the CommandManager and PropertyManager

You now can change the position of the CommandManager and the PropertyManager, placing them in different locations within the SolidWorks application or anywhere on your desktop (including on a different monitor if you are running multiple monitors).

- You can move the CommandManager and PropertyManager by dragging them.
- The CommandManager can dock automatically at the top or on either side of the SolidWorks window.
- The PropertyManager can dock in the manager area, just to the right of the manager area, or at the bottom corners of the SolidWorks window.

In the PropertyManager, click the title bar or the PropertyManager tab before dragging.

### Improving User Interface Consistency

The usage of **Enter** and **Esc** keys to accept and cancel PropertyManagers, dialog boxes, error messages, and commands has been improved.

- In general, when both **OK ✓** and **Cancel ✗** options exist for a command or dialog:
  - Pressing **Enter** now acts like **OK ✓**.
  - Pressing **Esc** now acts like **Cancel ✗**.
- If there is only a **Cancel ✗** option, **Enter** and **Esc** both act like **Cancel**.
• Where it would be inappropriate for Esc to exit the operation completely, you exit only the current dialog and preserve interim changes.
• You can ignore error and warning messages and continue working, or you can dismiss them using Enter or Esc.
This chapter includes the following topics:

- Materials
- Appearances

Materials

**Unified Materials Database and User Interface**

You can now use the same materials and the same user interface for materials in SolidWorks and SolidWorks Simulation.

The materials in the database are now read-only. Every material now has an associated default appearance and cross-hatch. You can create and edit custom materials.

**Displaying the Material Dialog Box**

To display the **Material** dialog box:

- In the FeatureManager design tree, right-click **Material** and select **Edit Material**.
  
The left side of the dialog box contains a tree of available material types and materials. Tabs on the right display information about the selected material. If Simulation is added in, more tabs appear.

**Working With Materials**

Use the **Materials** dialog box to apply a material, customize a material, and manage favorites. You can apply favorites from a shortcut menu in the FeatureManager design tree.

To work with materials:

1. **Open Materials\cstick-material.sldprt.**
2. Apply a standard material to the candlestick:
   a) Right-click **Material** in the FeatureManager design tree and select **Edit Material**.
   b) From the tree on the left, select **SolidWorks Materials > Copper Alloys > Copper**.
   c) Click **Apply**.

3. Create a custom material:
   a) In the list, right-click **Copper** and select **Copy** or press **Ctrl + C**.
   b) In the tree, scroll to the end of the list.
   c) Right-click **Custom Materials** and select **New Category**.
   d) Type **Custom Copper** for the name.
   e) Right-click **Custom Copper** and select **Paste** or press **Ctrl + V**.
   f) Rename the custom material to **Wrought copper**.
      - Select the material to display its properties.
   g) On the **Appearance** tab, select **wrought copper**.
   h) Select **Use material color** and click **Save**.
      - Every material has a default color. You can change the default by customizing the material, for example to make all gold components red.

4. Add the custom material to the Favorites list:
   a) In the materials tree, select **wrought copper**.
   b) On the **Favorites** tab, click **Add**.
   c) Select **Wrought copper**, then click **Up** several times to move it to the top of the list.
   d) Click **Close**.

5. Assign the custom material to the candlestick:
   a) Right-click **Copper** in the FeatureManager design tree.
   b) Select **Wrought copper** from the Favorites list.
Appearances

Appearances Include Colors and Textures

Colors and textures are now included in appearances. As a result, the visual attributes of a model are presented consistently in different modes, whether RealView is off or on, or whether the model is rendered in PhotoWorks.

- New icon families indicate that appearances and scenes no longer depend on RealView.
- A new tool, **Edit Sketch or Curve Color** (View toolbar), lets you edit colors for sketches and curves only.
- Colors or textures assigned in earlier versions of SolidWorks are converted to appearances named Default Plastic and Default Texture, respectively.
- The **Color and Optics** and **Texture** Property Managers have been removed.
- The Display Pane columns **Color** and **Texture** have been removed.

Modifying an Appearance

To modify an appearance, including color or texture, use the **Appearances** Property Manager:

1. Right-click a feature of the model.
2. Click the **Appearance Callout**, then select the face, feature, body, or part to affect.
3. Make changes in the **Appearances** Property Manager.

Pop-up Toolbar

The Appearance pop-up toolbar guides you to apply an appearance to the desired level of the model.

When you drag an appearance from the Task Pane to the graphics area, a pop-up toolbar appears, for example,

- Hover over each reference for a preview.
- Click to apply the appearance to the **Face**, **Feature**, **Body**, or **Part**.
- Alternatively, **Alt** + drag to apply the appearance and display the **Appearances** Property Manager.

Rough Draft Appearance

A new appearance, rough draft, is available on the **RealView/PhotoWorks** tab in the Task Pane. Select **Appearances > Miscellaneous > RealView Only Appearances**. Use this appearance to present a hand-drawn look, either for aesthetic reasons or to convey that a model is incomplete.
Changing the Rough Draft Style
You can change the rough draft style in the Appearances PropertyManager.

To change the rough draft style:

1. Open `PhotoWorks\cstick_rd.sldprt`.
2. Select RealView (View toolbar) to ensure that RealView is enabled.
3. In the Task Pane, on the Appearances/PhotoWorks tab, click Appearances > Miscellaneous > RealView Only Appearances.
4. Alt + drag the rough draft appearance to the graphics area.
5. In the Appearances PropertyManager, on the Color/Image tab, under Color, choose a new color, for example, blue.

💡 The background is always white. The line color changes from black to the new color.

7. Set Rotation to 30 degrees.

💡 The Rotation option is available for some mapping styles, including Planar. Changing the rotation can give the model a more hand-drawn look.

9. Click ✓.
To enhance the rough draft appearance, remove tangent edges. Click View > Display > Tangent Edges Removed.

**Lights and Shadows**
You can change the appearance of rough draft by working with lighting.

- The rough draft appearance interacts with one directional light only. If you have configured two directional lights, rough draft responds only to the first. If you disable the first directional light, rough draft responds to the second light.
- Rough draft ignores these lighting aspects: Ambient, Diffuse, Specular.
- You can combine rough draft with the studio scene Ambient Occlusion, which provides more realistic shading for the model.
This chapter includes the following topics:

- Move, Copy, and Rotate in 3D Sketches
- Improved Functionality for Splines
- Creating Equation Driven Curves
- Ghost Images of Missing Sketch Entities
- Numeric Sketch Input
- Offsetting Infinite Lines
- Repair Sketch Enhancements
- Resizing Sketches in Instant3D
- Slot Sketch Entity
- Stretching Sketch Geometry
- Using Blocks in Sketches
- Sketch Dimensions of Zero and Negative Values

**Move, Copy, and Rotate in 3D Sketches**

You can move, copy, and rotate entities and planes in 3D sketches.

If you have an active plane selected, the move, copy, and rotate actions work the same as in 2D sketches. For example, you can move objects along only the X and Y axes of the active plane.

**Moving 3D Sketch Entities**

To move a 3D sketch entity:

1. In 3D Edit Sketch mode, click **Move Entities** (Sketch toolbar) or **Tools > Sketch Tools > Move**.
2. Select the sketch entities to move.
   
   X, Y, and Z directional arrows appear in the sketch and delta fields for each axis appear under **3D Move** in the PropertyManager.
3. Move the sketch entities using one of these methods:
   - In the sketch, drag the X, Y, or Z directional arrow.
   - In the PropertyManager, under **Translate**, specify values for location changes on the X, Y, and Z axes.

**Improved Functionality for Splines**

The functionality for splines is enhanced.

- You can trim the ends of offset splines.
- Splines have curvature applied to their ends. Previously, they had zero curvature at their ends.
- In curvature combs for multiple connected curves, the software spaces the spines equally along the length of the curve.

**Creating Equation Driven Curves**

You can click **Equation Driven Curve** to create a curve by specifying the equation that defines that curve.

Equations defining a curve specify Y as a function of X. You can use any functions that are supported in the **Equations** dialog box. For example, you can build complex equations like this:

\[ y = 2*(x + 3*\sin(x)) \]

To create an equation driven curve:

1. In a sketch, click **Tools > Sketch Entities > Equation Driven Curve**.
2. Specify the equation parameters in the PropertyManager:
   - **Equation**: Specify the equation that defines the curve, where Y is a function of X. If you specify an equation that cannot be resolved, the text color changes to red.
   - **Parameters**: Specify the range of values for X, where \( X1 \) is the starting point and \( X2 \) is the ending point. For example, \( X1 = 0 \) and \( X2 = 2*\pi \).
You can fix the end points of the curve using 🗿. If you select Lock 🗿, the starting or ending point is fixed. If you clear Lock 🗿, you can drag the starting or ending point along the curve and PropertyManager values are updated.

Ghost Images of Missing Sketch Entities

If the reference for a sketch relation or dimension is missing, you can display a ghost image of that missing reference by hovering over or selecting the dangling relation or dimension.

The ghost image has the same size, shape, location, and orientation as the original entity.

The ghost image appears whenever you select a relation or dimension to that reference (for example, if you start the Display/Delete Relations or sketch entity PropertyManager).

Displaying a Ghost Image of a Missing Sketch Entity

To display a ghost image of a missing sketch entity:

1. Open a drawing document consisting of multiple sketches.
   For example, this drawing consists of two sketches, one containing the top line and the other containing the bottom line and the angular dimension between the lines.

2. Delete the sketch that contains the top line.
   The drawing now looks like this:

   Notice how the shading indicates that the dimension is dangling now that you deleted the top line.

3. Hover over or select the angular dimension.
   A ghost image of the missing line appears.
Numeric Sketch Input

You can specify numeric input as you create lines, rectangles, circles, and arcs.

**Enabling Numeric Input**

To enable numeric input:

1. Click **Options > Sketch**.
2. Select **Enable on screen numeric input on entity creation**.

**Specifying Numeric Input**

To specify numeric input:

1. In a sketch, click **Corner Rectangle** (Sketch toolbar) or **Tools > Sketch Entities > Rectangle**.
2. Click and release to start the rectangle, and then move the pointer.

   Fields appear for each side of the rectangle. One field is ready to accept numerical input.

3. Type 1, and then press **Tab** in a 2D sketch, or **Shift Tab** in a 3D sketch.

   The width is set to 1 and focus changes to the other side.

4. Type 2, and then press **Enter**.
The rectangle is sized to the length you specified and the numeric fields disappear.

Offsetting Infinite Lines
You can offset infinite lines.

Repair Sketch Enhancements
Repair Sketch now locates more types of errors in sketch elements and lets you repair some interactively.

Repair Sketch automatically repairs:
• Overlapping sketch lines and arcs
  Repair Sketch merges these into a single entity.

Repair Sketch highlights these errors:
• Sketch entity gaps or overlaps smaller than the maximum gap value specified in Repair Sketch

  Gaps or overlaps larger than that value are considered intentional.

• Small sketch entities (that is, entities whose chain length is less than twice the maximum gap value)
• Any point shared by three or more entities

If an error of this type is found, you can repair the error in the sketch. Clicking Previous or Next moves to another error.

Click to toggle the magnifying glass or a circle to highlight the error in the sketch. For details, see Using the Magnifying Glass on page 17.

Resizing Sketches in Instant3D
In Instant3D, you can use handles along the outer border to resize a sketch or block.

To resize a sketch in Instant3D:

1. If Instant3D is not enabled, click Instant3D (Features toolbar).
2. In the FeatureManager design tree, select a sketch.
   Anchor points appear along the border of the sketch.

3. Drag an anchor point.
The sketch resizes, maintaining its proportions. If you drag an edge or corner, the opposite edge or corner is fixed.

For example, if you drag the middle right anchor, the left side remains fixed and the sketch is resized proportionally.

If you press Alt before dragging the anchor, the opposite edge or corner is not fixed. The sketch resizes proportionally, maintaining its original center point.

**Slot Sketch Entity**

You can insert slots into sketches and drawings.

There are four types of slot sketch entities:

- Straight slot
- Centerpoint straight slot
- Three point arc slot
- Centerpoint arc slot

**Creating a Straight Slot**

To sketch a straight slot:

1. In a sketch, click **Straight Slot** (Sketch toolbar) or **Tools > Sketch Entities > Straight Slot**.
2. In the sketch, click to specify the starting point for the slot.
3. Move the pointer and click to specify the length of the slot.

4. Move the pointer and click to specify the width of the slot.

Stretching Sketch Geometry

In a 2D sketch, you now can stretch multiple sketch entities as a single group, rather than having to modify each individual length.

To stretch sketch entities:

1. Click Stretch Entities (Sketch toolbar, under Move Entities) or Tools > Sketch Tools > Stretch Entities.
2. Select entities for Entities To Stretch and then right-click.
   
   For example, select the three lines shown:

3. Under Parameters, select a method:
   
   - **From/To.** Drag the entities to stretch the geometry:
     a) Click one of the entities.
     b) Drag to stretch.
     c) Right-click and then click .
   
   - **X/Y.** Specify values for the change in width (X) and height (Y) for the entities.
     
     The sketch entities change to the new size. For example, if you specified a 0.50 change in width but no change in height:
Using Blocks in Sketches

Several enhancements have been made to working with blocks in sketches.

**Saving a Sketch to a Block File**

You can save a sketch directly to a block file, rather than creating a block in your sketch first and then saving that block.

To save a sketch to a block file:

1. Create a sketch.
2. Click **Save Sketch as Block** (Blocks toolbar) or **Tools > Blocks > Save**.

**Saving Sketches in the Design Library**

You can save a sketch as a block in the Design Library. Previously, you had to create the block in the sketch before saving it in the Design Library.

To save a sketch as a block in the Design Library:

1. In the FeatureManager design tree, select the sketch to add to the Design Library.
2. In the Design Library, click **Add to Library**.
3. In the PropertyManager, under **Save To**, type a file name and select a Design Library folder.
4. Click ✓. The sketch is saved as a block in your Design Library.

**Sketch Dimensions of Zero and Negative Values**

You can specify zero and negative values for sketch dimensions.

In the PropertyManager or the **Modify** dialog box, reverse the sense of a position dimension by:

- Clicking **Reverse Direction**
- Typing a negative number
Reversing a Position Dimension

To reverse a position dimension in a sketch:

1. Select a position dimension.

2. In the PropertyManager, under **Primary Value**, click **Reverse Direction**. The location of the object relative to the reference point changes to the reverse of the original value. In this sketch, the line position is fixed and the dimension to change is from the line to the top of the rectangle:

![Initial Sketch](image)

If you click **Reverse Direction**, the top line in the rectangle now appears 0.03 units above the line:

![Reversed Sketch](image)
This chapter includes the following topics:

- General
- Boundary Features
- Extrudes and Slots
- Fastening Features
- Freeform Features
- Instant3D
- Lip and Groove Fastening Features
- Ribs
- Solid Sweep Cuts

**General**

**Missing Reference Ghosting**

When an entity used as a reference in a feature is missing, a ghost of the missing reference appears in the graphics area, and a warning message appears in the PropertyManager. Ghosting is supported for parts and assemblies.

The ghost appears in the same location with the same size, shape, and type as the original reference. For example, a planar face is represented by a planar ghost.

To set the ghosting color, click **Options > System Options > Colors**. Under **Color scheme settings**, click **Selected Item Missing Reference**.

For more information, see Ghost Images of Missing Sketch Entities on page 28.

**Viewing Missing Reference Ghosts**

You can view ghosts that give you information about the size, location, and type of references that are missing.

1. Open `Features\Fillet_MissingRef.sldprt`
2. Expand **Extrude1** and edit **Sketch1** to remove the upper-right corner of the sketch, approximately as shown.

3. Exit the sketch. The **What's Wrong** dialog box reports an error in **Fillet2**, which also shows as an error in the FeatureManager design tree.

4. Close the dialog box.

5. In the FeatureManager design tree, right-click **Fillet2** and select **Edit Feature**. In the PropertyManager, **Missing** Edge<1> appears in **Edge, Faces, Features and Loops**. A ghost of the missing edge used by the fillet appears in the graphics area.

6. Select **Missing** Edge<1> in the PropertyManager. The missing reference ghost is highlighted.

7. Select the top-most edge as a replacement for the missing edge, and the lower edge as a new edge for **Edges, Faces, Features and Loops**.
The ghost disappears from the graphics area. **Missing** Edge<1> disappears from the PropertyManager.

8. Click ✓. Fillet2 no longer shows an error in the PropertyManager.

**Other Missing Reference Messages**
When an entity that was originally used to form a contour, region, closed or open group, or closed or open loop is missing, features such as lofts, sweeps, or boundaries fail. In these cases, **Error**<Sketch number> rather than **Missing** appears in the PropertyManager.

Select **Error** Sketch1 in the PropertyManager to highlight the failing sketch in this loft.

Loft after you repair the sketch

For external references that are out-of-context (Feature name suffix shows as ->?), **External**<Reference information> rather than **Missing** appears in the PropertyManager.

To set the color for missing external references, click Options > System Options > Colors. Under Color scheme settings, choose Selected Item 3.

**Boundary Features**
The boundary feature now creates solid boss/base and cut features similar to solid extrude, loft, revolve, and sweep features. Boundary produces very high quality, accurate features useful for creating complex shapes for the consumer product design, medical, aerospace, and mold markets.
See Boundary Overview and Boundary PropertyManager in the help.

**Extrudes and Slots**

When you create an extrude of a slot sketch, you can view the slot's central temporary axis. This capability is particularly useful for mating fasteners at the center of slots in assemblies.

For more information, see Slot Sketch Entity on page 31.

**Fastening Features**

Several fastening feature PropertyManagers are enhanced:

- Favorites are now available.
- Improved images clearly show which area each dimension affects.

**Snap Hook Groove** PropertyManager

**Freeform Features**

Freeform features are enhanced.
• You can now create freeforms on patches with any number of sides. Previously you could create freeforms on four-sided patches only.

• You can now rotate the mesh preview to align it to the deformation you create. A protractor displays the rotation angle.

---

**Instant3D**

**Instant3D in Assemblies**
Assemblies now support Instant3D. You can use Instant3D to edit components within the assembly, or to edit assembly level sketches, assembly features, and mate dimensions.

**Using Instant3D in Assemblies**
To use Instant3D in assemblies:

1. Open `Instant3D\Assembly\Instant3D.sldasm`.  
2. Select the **Hole** feature in the FeatureManager design tree to show its dimensions.

3. Select the hole dimension to display the current value (0.6) in the callout, then type 1.2 and press **Enter**. The hole resizes to 1.2.

4. Expand **Mates** and select the **Distance1** mate.

5. Drag the Instant3D circle on the part shown to modify the mate.

Use the ruler to drag a specified distance.
Editing Sketches in Instant3D
You can use Instant3D to edit internal sketch contours.
Drag manipulators to reposition internal sketch contours using rulers. This functionality works for boss and cut features and is available for these sketch entities:
- Circles
- Polygons
- Center rectangles
- 3 point center rectangles

Editing Sketches using Instant3D
To edit a sketch using Instant3D:

1. Open Instant3D\EditSketch.sldprt.

The sketch for this extrude contains an internal sketch polygon that you can reposition.

2. Select the face shown.
   Manipulators appear.

3. Select the contour manipulator.
   The pointer changes to .

4. Drag the manipulator away from the nearby model edge.
   A ruler appears so you can specify the distance.
You can drag the contour manipulators to move the contour horizontally or vertically. Drag the wing to drag the contour anywhere along its plane. Use the resize manipulator to resize the contour.

**Instant3D Live Section Planes**

Instant3D Live Sections are enhanced to improve usability.

You can display multiple Live Sections persistently and they are automatically saved with the model. The user interface provides improved control of plane size through plane handles, triad improvements, and shortcut menu commands.

**Using Instant3D Live Section Planes**

To learn about Instant3D Live Section enhancements:

1. Open `Instant3D\LiveSection.sldprt`.

2. Click `Live Section Plane` (Reference Geometry toolbar) or **Insert > Reference Geometry > Live Section Plane**.
   - The PropertyManager appears, prompting you to select a sectioning plane.

3. Select the front face shown.

   The Live Section appears with the default name *Live Section Plane1*. The plane is sized based on the selected face. The plane has handles you can drag to resize it. The **Live Section Planes** folder, which stores all Live Sections, appears in the FeatureManager design tree.

4. In the **Live Section Planes** folder, select the plane and rename it to **LSP1**.

5. Click anywhere in the graphics area.
The Live Section is deactivated. It changes color and the plane handles disappear. The triad also disappears.

6. Right-click the plane's border and select **Fit to Part**. The plane size becomes large enough to section the entire body.

💡 Other shortcut menu items allow you to reset the Live Section to its original state, or hide it.

7. Right-click the plane's border and select **Show Triad**.

8. Drag the triad's blue arrow to position the Live Section approximately as shown.

The ruler lets you position Live Sections using specific dimensions.

💡 When you use the triad rings to rotate Live Sections, a protractor lets you set precise angles.

💡 To measure entities, click **Tools > Measure** and select the entity.

9. Click **Live Section Plane** (Reference Geometry toolbar) or **Insert > Reference Geometry > Live Section Plane** and select the right face shown. Rename the plane to **LSP2**.
A second Live Section appears while LSP1 remains displayed. You can create multiple Live Sections that are all stored in the **Live Section Planes** folder.

10. Right-click LSP1 in the graphics area and click **Hide**.
   The icons in the **Live Section Planes** folder reflect the displayed state of the planes.
   You can also click **Hide Triad** to temporarily hide the triad.

11. Click **View > Live Section Planes** to hide all Live Sections.

**Instant3D and Mirrors or Patterns**
You can use Instant3D to manipulate mirrored or patterned geometry. The manipulators available on the selected transformed geometry match those available on the corresponding seed geometry. When you drag transformed geometry, the entire model updates, including seed geometry.

**Instant3D and Move Face Features**
You can edit **Move Face** features using Instant3D functionality.
- For **Offset** and **Translate**, drag the dimension or arrow.
• For **Rotate**, drag the angle dimension.

**Instant3D Weldments**
Instant3D now works on weldment parts for 2D and 3D weldments.
Drag Handles

Select the face to drag. The drag arrow appears in the closest available direction for drag. You can move the weldment body to elongate attached bodies and the guide sketch.

Drag the handle.

Resized weldment part

Drag an end face to elongate the structural member.

Drag handles also work if the side face orientation is not in the same plane as the guide sketch. Instant3D respects the general direction of the drag handle, so the guide sketch and attached bodies expand or contract.
Other Examples

As you drag a structural member segment, a preview of the selected segment shows the location.

Select the structural member face to drag

Drag preview of new location

Final position

Lip and Groove Fastening Features

You can create lip and groove fastening features to align, mate, and hold together two plastic parts. The lip and groove features support multibodies and assemblies.

Click **Lip / Groove** (Fastening Features toolbar) or **Insert > Fastening Feature > Lip / Groove** and set the options.
Ribs

When applying draft to a rib feature, you can now specify the thickness of the rib at the intersection of the rib with the wall. Previously, you could only specify the thickness at the sketch plane.

Solid Sweep Cuts

Solid sweep cuts are enhanced.
<table>
<thead>
<tr>
<th>Enhancement</th>
<th>SolidWorks 2008</th>
<th>SolidWorks 2009</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface quality is improved</td>
<td></td>
<td></td>
</tr>
<tr>
<td>You can create a solid sweep cut along a non-tangent path</td>
<td></td>
<td>Not supported</td>
</tr>
<tr>
<td>Enhancement</td>
<td>SolidWorks 2008</td>
<td>SolidWorks 2009</td>
</tr>
<tr>
<td>-------------</td>
<td>----------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Extra lines at the end of solid sweep cuts are removed</td>
<td><img src="image1.jpg" alt="Image" /></td>
<td><img src="image2.jpg" alt="Image" /></td>
</tr>
<tr>
<td>You can generate solid sweep cuts that were not supported</td>
<td><img src="image3.jpg" alt="Image" /></td>
<td><img src="image4.jpg" alt="Image" /></td>
</tr>
<tr>
<td>Tool body geometry is consumed by the solid sweep cut.</td>
<td>Tool body geometry was not consumed and the model had an incorrect mass property.</td>
<td>Tool body geometry is consumed.</td>
</tr>
</tbody>
</table>
This chapter includes the following topics:

- Dual Dimensions for Measurement Results
- Dimensions in Mirrored and Derived Parts
- Custom and Default File Properties in Equations
- Changing Parts Display Characteristics
- Reattach Derived Parts
- Custom Properties Assigned to Parts
- Sensors
- Mold Design
- Sheet Metal
- Weldments

Dual Dimensions for Measurement Results

You can configure the Measure tool to display results using two different units of measure. For example, you can specify both millimeters and inches for display in the Measure dialog box, measurement callouts, and the status bar.

To use dual dimensions:
1. Click **Measure** (Tools toolbar) or **Tools > Measure**.

2. In the **Measure** dialog box, click **Units/Precision**.

3. In the **Measure Units/Precision** dialog box, select **Use custom settings** and select the first length unit.

   *If you select **Use document settings**, dual units are only shown if you have enabled dual units on the **Document Properties** tab of the **Options** dialog box.*

4. Click **Use Dual Units** and select the second unit.

5. Click ✓.

**Dimensions in Mirrored and Derived Parts**

When you create a mirrored or derived part, you can import the sketch and feature dimensions of the original part. While these dimensions are not editable, they can be used in drawings created from the mirrored or derived part.

To import dimensions when you mirror or derive a part, select **Model dimensions** in the **Insert Part** PropertyManager.

- Original part showing sketch dimension

- Mirrored part showing imported dimensions

- Drawing based on mirrored part
Custom and Default File Properties in Equations

You can use custom and default file properties to drive equations in parts and assemblies. The Add/Edit Equation dialog box and the Equations folder in the FeatureManager design tree provide direct access.

To add custom and default file properties to equations:

1. Do one of the following to display variables, custom file properties, and default file properties:
   - In the Add/Edit Equations dialog box, in the lower right corner, click ↓.
   - In the FeatureManager design tree, right-click Equations and select Show File Properties.

   Icons differentiate the variables and file properties:
   - Global variable
   - Custom Property
   - Default Property

2. Click the variable or file property in the dialog box list or FeatureManager design tree to add it to the equation.

Changing Parts Display Characteristics

You can use the Display Pane to change display characteristics of parts.

Click ▼ at the top of the FeatureManager Design tree to expand the Display Pane and change display characteristics using these controls:

- Hide/Show
- Display Mode
Appearance

Transparency

For all parts, you can change the appearance (material and color) and transparency of selected features of the part.

For multibody parts, you can also change the hide/show state and display mode (for example, Shaded, Hidden Lines Visible, Wireframe) of a selected body.

Reattach Derived Parts

The functionality of the Split feature has been expanded.

New functions include:

- Reattach of existing files while editing the Split feature.
- The option to automatically reattach parts when you change the trim tools.
  
  The results of the reattach process are reported in balloon messages.
- Shortened callouts for better readability.
  
  Tooltips provide the full path.
- An Attach File dialog box that lets you reattach existing derived parts that are related to the split feature. Visual previews help you identify parts.

  You can also specify new names for derived parts.

  The Save All Bodies button has been renamed to Auto-Assign Names. You still use this control to assign new part names to unassigned bodies created when you cut the part.
You can reattach derived parts to:

- A specified stock part file
- Specific bodies in the stock part file

Stock part split by a sketch

Reattaching Existing Derived Parts

When you edit a split part feature, you can reattach the resultant bodies to existing derived parts. You can select to attempt to reattach the bodies automatically. When a body cannot be reattached automatically, the Assign File dialog box lets you select the part to which to attach the body.

To reattach derived parts:

1. Open Parts\Split-part.SLDPRT.
2. In the FeatureManager design tree, right-click the Split1 feature and click Edit Feature.
3. In the PropertyManager, under Trim Tools, clear Sketch3 and select Sketch4 as the trim tool to which reattach parts.
4. Click Cut Part.
5. When prompted to attach split bodies to existing files, click Yes. A message reports the result. In this case, some, but not all of the bodies are reattached.

⚠️ The software attempts to match parts with bodies using internal information. Changes made to the model may cause unintended results. Always inspect the results to make sure they are correct.

6. Click the callout for Body2, the body that was not reattached.
7. In the Assign File dialog box, select Existing File.
8. Use the drop-down list to select bodya.sldprt, which was not automatically reattached. A preview shows the part.
9. Click OK in the dialog box, and then click ✓ in the PropertyManager.

Reattaching Parts When You Change Trim Tools

When you change Trim tools, you can create new parts as well as reattach existing parts, for example, when the number of bodies created with the new trim tool is greater than the number of existing parts.
To reattach parts when you change trim tools:

1. Open Parts\Split-part2.SLDPRT.
2. In the FeatureManager design tree, right-click the Split1 feature and click Edit Feature.
3. In the PropertyManager, under Trim Tools, clear Right Plane and select Sketch3 as the new trim tool.
4. Click Cut Part.
5. When prompted to attach split bodies to existing files, click Yes. A message reports that some of the bodies have been reattached.
6. Click the callout for Body 3, the body that has not been reattached. In the Assign File dialog box, both files listed in the Existing Files drop-down list have already been reattached.
7. Select New file, and then click the Browse button to open the Save As dialog box.
8. Type Middle as the name of the derived part and click Save.
9. Click ✓.

Custom Properties Assigned to Parts

You can assign custom and configuration-specific properties from the new Custom Properties tab in the Task Pane. See Custom Properties on page 15.

Sensors

Sensors monitor selected properties in parts and assemblies and alert you when values deviate from the limits you specify. See Sensors on page 74.

Mold Design

Analysis Tools

Analysis tools can now run continuously and report changes as the model is changed. The analysis tools are:

• Draft Analysis. Enhancement of the previous Draft Analysis tool.
• Undercut Analysis. Enhancement of the previous Undercut Detection tool.
• Parting Line Analysis. New tool to analyze potential parting lines as you design molded parts.

You still need to use Parting Line (Mold Tools toolbar) to add a parting line feature.

After running an analysis:

• You can turn the display of the results on and off, similar to Zebra Stripes.
The results update dynamically when the geometry of the part changes.

Display of draft analysis results:

Sheet Metal

Convert to Sheet Metal
You can convert a solid or surface body into a sheet metal part using the **Convert to Sheet Metal** command. The solid body can be an imported sheet metal body.

After you create the part, you can apply all sheet metal features to it.

Use the **Convert to Sheet Metal** command with:

- Solid or surface bodies that have:
  - No shells or fillets
  - Either a shell or fillets
  - Both a shell and fillets

- Imported parts that are already in the form of a sheet metal part

Solid part                                Sheet metal part with bends highlighted
Sheet metal part flattened

Converting a Solid Part to a Sheet Metal Part
You use the **Solid to Sheet Metal** PropertyManager to specify the thickness and default bend radius for the part. When you select the bend edges, the required rips edges are selected automatically so that the completed part can be flattened.

To convert a solid part to a sheet metal part:

1. **Open** SheetMetal\Solid_to_SM.SLDPRTR.
2. **Click** Convert to Sheet Metal (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**.
3. **In the PropertyManager:**
   
a) **Under Sheet Metal Parameters**, select the top face as the fixed face for the sheet metal part.
   
b) Set the sheet thickness to 1mm and the bend radius to 2mm.
   c) **Select Reverse Thickness**.
   d) **Under Bend Edges**, select the edges of the top face as bend edges, then continue selecting the edges that are parallel to the one highlighted below. Select a total of 12 edges.

💡 Changing the display style to **Hidden Lines Visible** makes it easier to see all bend edges.
Rip edges are shown under Rip Edges found, based on the bend edges you select.

💡 Under Rip Sketches, you can manually select rip edges or sketch entities on which to create rips.

In the graphics area, callouts are attached to the bend and rip edges. You can use the callouts to change the bend radii and rip gaps.

e) For a tighter relief, under Auto Relief, change the relief type to Tear, or specify a smaller relief ratio. The relief ratio can be a negative number.

f) Click ✓.

4. Click Flatten (Sheet Metal toolbar) to flatten the part using the bends and rips you specified.

Converting an Imported Sheet Metal Part
You can convert any imported sheet metal type part to a fully functional SolidWorks sheet metal part that can be flattened.

The imported part must be a constant thickness.

⚠️ If the part you are converting has a formed feature, it is deleted. You can reapply the feature after the conversion.

To convert an imported sheet metal part:

1. Import Sheetmetal\Sheet_Metal_Import.x_t into SolidWorks.

2. Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal > Convert To Sheet Metal.

3. In the PropertyManager, under Sheet Metal Parameters, select the middle face as the fixed face.

4. Under Bend Edges, click Collect All Bends.
   This selects all pre-existing bends in the imported part and detects the thickness of the part.
You can also manually select bend edges.

5. Click ✓.

Converting Using Rip Sketches
When a rip is required to create a sheet metal part, you can use 2D and 3D sketches to define the rip. You must create the sketch before converting the solid body to a sheet metal part.

To use a rip sketch when converting a solid body:

1. Open the part.
2. Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal > Convert To Sheet Metal.
3. In the PropertyManager, under Sheet Metal Parameters, select the fixed face.
4. Under Bend Edges, select the bend edges.
5. Under Rip Sketches, select the sketch you created to define the rip.
6. Click ✓.

Expanded Sheet Metal Gauge/Bend Table
The sheet metal gauge table has been expanded to let you associate a bend allowance, bend radius, or k-factor with any combination of thickness (gauge), bend radius, and material.

The sheet metal gauge tables and bend tables have been combined so that both gauge table and bend table values can be read into the Sheet Metal Gauges PropertyManager.

You can still use gauge tables and bend tables that have the old format. Only old-style bend tables can be read into the Bend Table dialog box.

The Gauge No., Thickness, and Radius values in the new tables populate the corresponding fields in the Sheet Metal Gauges PropertyManager.

The value in the Angle column is fed into the Angle drop-down list in the Edge Flange PropertyManager.

To edit the new gauge/bend tables click Edit > Bend Table > Edit Table.

To use the new gauge tables:

1. Right-click a sheet metal part and click Edit Feature.
2. In the PropertyManager, under **Sheet Metal Gauges**, select *Use gauge table*.
3. Select a new format gauge table by using the drop-down list or browsing to it.

![Sheet Metal Gauges](image)

4. Under **Sheet Metal Parameters**, select the gauge. The thickness and radius are calculated from the table. You can override these values.
5. Under **Bend Allowance**, you can use the drop-down list to select the type of bend calculation to use (*K-Factor*, *Bend Allowance*, or *Bend Deduction*) or to switch from the gauge table to an old-style bend table.

6. Click ✅.

**Beveled/Chamfered Edges with Sheet Metal**

SolidWorks maintains bevels and chamfers while you work with sheet metal parts. Beveled and chamfered edges are now maintained when you:
- Flatten cylindrical sheet metal parts
  
  Cylinder with countersunk hole  Cylinder flattened

- Flatten a part with a chamfer along an edge that traverses a bend
  
  Chamfer across bend  Part flattened

- Use other sheet metal commands like Sketched Bend, Jog, and Hem
- Insert bends into parts with bevels or chamfers
The bevels or chamfers cannot be on an edge that intersects a bend.

Chamfers and bevels are only maintained when the sheet metal parts are created in SolidWorks 2009.

**Cross Breaks**
You can add a cross break to a sheet metal part such as a duct to stiffen it, deflect water, etc.

Cross break characteristics:
- You can flatten sheet metal parts with cross breaks.
- You can add an edge flange or miter flange to the edge of a face with a cross break.
- The corners of the cross break must be at the ends of the edge.
- When you add a cross break, the part's dimensions are not changed.
- You can edit the cross break sketch to move corners and change relationships.
- When you create a drawing from a part with a cross break, the flattened view is labeled with the bend direction, bend radius, and bend angle.

To add a cross break to a sheet metal surface:

1. Click **Cross Break** (Sheet Metal toolbar) or **Insert > Sheet Metal > Cross Break**.
2. In the PropertyManager, select:
   - The face on which to create the cross break
   - The direction of the cross break
   - The break radius
   - The break angle
3. Click ✓.
Weldments

Groups

You can now define a weldment group, a collection of related segments in a structural member. Configure a group to affect all its segments without affecting other segments or groups in the structural member.

You can define a group in a single plane or in multiple planes. A group can contain one or more segments. A structural member can contain one or more groups.

Types of groups are:

Contiguous  A continuous contour of segments joined end-to-end. The end point of the group can optionally connect to its beginning point.

Parallel  A discontinuous collection of parallel segments. Segments in the group cannot touch each other.

When you define a group, the second segment you select determines the group type. To create a contiguous group, select two connecting segments. To create a parallel group, select two parallel segments.

After you define a group, you can operate on it as a single unit. You can:

- Specify the corner treatment for the segments in the group.
- Create weld gaps between segments to allow space for weld beads.
- Mirror the profile of a single group.
- Align a group without affecting the rest of the structural member.

Working With Groups

To work with groups:

1. Open Weldments\weldment_groups.sldprt.
2. Configure the structural member:
   a) Click Structural Member (Weldments toolbar) or Insert > Weldments > Structural Member.
   b) Pin the PropertyManager.
   c) Under Selections:
      - Select ansi inch in Standard.
      - Select c channel in Type.
      - Select 3 x 5 in Size.
3. Create groups:
a) Create Group1 by selecting the highlighted segments:

![Diagram of Group1]

💡 To create a contiguous group, ensure that the second segment you select connects to the first.

b) Click **New group** to create Group2 from the highlighted segments:

![Diagram of Group2]

c) To create Group3, right-click, select **Create New Group**, and select the highlighted segments:

![Diagram of Group3]

d) In **Groups**, select each group. In turn, their segments are highlighted in the graphics area and their segment names are listed in **Path segments** under **Settings**.

4. Apply corner treatments and create weld gaps for Group1:

💡 A weld gap provides space for a weld bead without requiring you to shorten the segments.

a) In **Groups**, select **Group1**.

b) Select **Apply corner treatment** and click **End Miter**.

c) Set **Gap between Connected Segments in Same Group** to 10 and press **Tab**.

💡 Use **Gap between Different Group Segments** to control the gap at intersections with other groups.
d) Zoom to the lower left corner of Group1 to see the mitered corner with a weld gap. The changes you made affect Group1 only.

5. Override the corner treatment for the lower-left corner:
   a) Click the corner.
   b) In the dialog box, select **Set corner specific weld gaps**.
   c) Set **Gap between Connected Segments in Same Group** to 2.
   d) Click ✔.
   e) Inspect the other corners of Group1 to compare their weld gaps.

6. Set the view orientation to Trimetric ✔.
   Note that the channels in Group2 point inward.

7. Mirror the profile of Group2:
   a) In **Groups**, select **Group2**.
   b) Under **Settings**, select **Mirror Profile**.
   c) Select **Vertical Axis**.
      The channels now point outward.

8. Rotate one group without rotating the entire structural member:
   a) In **Groups**, select **Group3**.
   b) Under **Settings**, set Rotation Angle to 45 and press **Tab**.
   c) Rotate the model to verify that members of Group3 are at an angle, while other groups are unaffected.

9. Unpin the PropertyManager and click ✔.

**Working with Enhanced Trim and Extend Tool**
The trim and extend tool splits a structural member that is crossed by another structural member. You can also specify a weld gap between the structures, keep or discard either split side, or extend a structure.

To work with the enhanced tool:

1. **Open** `Weldments\wld-trim-extend.sldprt`. 
2. Click **Trim/Extend** (Weldments toolbar) or **Insert > Weldments > Trim/Extend**.

3. Under **Corner Type**, click **End Trim**.

4. Select Structural Member2 and Structural Member3 for **Bodies to be Trimmed**.

5. Under **Trimming Boundary**:
   a) Select **Bodies**.
   b) Select Structural Member4 for **Face/Bodies**.
   c) Select **Weld Gap** and set **Weld Trim Gap** to 8. The structures are trimmed with a visible gap. Callouts let you keep or discard bodies.

6. Click **keep** on one callout to toggle to **discard**. Preview mode shows which structures to retain or delete.

7. Pin the PropertyManager and click **✓**. In place of the body you discarded, you see its sketch line.

8. Extend the top structure:
   a) Rotate the model so you can see the inner face of the right side.
   b) Select Structural Member1 for **Bodies to be Trimmed**.
   c) Under **Trimming Boundary**, click **Face/Plane**.
   d) Select the inside face of Structural Member5 for **Face/Bodies**.

9. Click **✓**. The body extends across the model.

**Creating Gussets with Chamfers**
You can create a gusset with a chamfer that allows room for a weld bead under the gusset.
To create a gusset with a chamfer:

1. Open Weldments\gusset-sample.sldprt.
2. In the FeatureManager design tree, right-click Gusset1 and select Edit Feature.
3. In the PropertyManager, under Profile, click Chamfer.
4. Set the height, Chamfer Distance5, to 30.
5. Set the width, Chamfer Distance6, to 50.

💡 You can specify the chamfer width (d6) or the chamfer angle (a2).

6. Click ✔.

**End Caps**

Enhancements:

- You can now simultaneously add end caps to multiple faces at the same time. In the End Cap PropertyManager, add multiple faces to Face.
- When you add an end cap, you can now project it inward, retaining the original length of the structure. Previously, you could project the end cap outward only, which extended the length of the structure.

In the End Cap PropertyManager for Thickness direction, select:
Outward  ❖

Inward  ❖ (New)

**BOMs and Weldments**
You can include detailed weldment cut lists in indented BOMs and you can insert the BOMs in weldment part files.

For more information, see *Detailed Weldment Cut Lists in BOMs* on page 90.
This chapter includes the following topics:

- General
- Large Assemblies
- Assembly Features in Parts
- Bills of Materials in Assembly Documents
- Clearance Verification
- Hinge Mates
- Sensors
- SpeedPak

General

**Custom Properties**
You can assign custom and configuration-specific properties from the new **Custom Properties** tab in the Task Pane. See Custom Properties on page 15.

**Design Clipart**
You can now add Design Clipart in assemblies.
Entities you can add as assembly features include:

- Sketches
- Features that remove material

Entities you can add while in **Edit Component** mode include:

- Sketches
- Features that add or remove material.

**Equations**
You can use custom and default file properties to drive equations in parts and assemblies. The **Add/Edit Equation** dialog box and the **Equations** folder in the FeatureManager design tree provide direct access. See Custom and Default File Properties in Equations on page 53.

**Instant3D in Assemblies**
Assemblies now support Instant3D. You can use Instant3D to edit components within the assembly, or to edit assembly level sketches, assembly features, and mate dimensions. See Using Instant3D in Assemblies on page 39.
Measurements

You can configure the **Measure** tool to display results using two different units of measure. For example, you can specify both millimeters and inches for display in the **Measure** dialog box and measurement callouts. See Dual Dimensions for Measurement Results on page 51.

Missing Reference Ghosting for Mates

When an entity used as a reference in a mate is missing, a ghost of the missing reference appears in the graphics area, and a warning message appears in the PropertyManager. See Missing Reference Ghosting on page 35.

Selection Tools

**Select Toolbox** on the **Select** flyout button (Standard toolbar) selects all Toolbox components in the assembly.

Large Assemblies

Some enhancements are particularly useful when you work with large assemblies.

Performance

Enhancements have been made to improve performance for very large and complex assemblies. Commands with improved performance include:

- Window selection
- Copying and adding sub-components
- Deleting sub-assemblies
- Saving assemblies
- Adding mates
- Editing parts

When working in drawings of very large and complex assemblies, commands with improved performance include:

- Panning and zooming
- Inserting and selecting dimensions
- Adding and switching sheets
- Inserting views (initial, projected, section, and detail views)
- Switching from the drawing to the assembly and back
- Creating a drawing from the assembly
- Changing the view to shaded

💡 The performance improvements listed above are most noticeable in very large and complex assemblies.

Assemblies Larger than One Kilometer

You can now create assemblies that are larger than one kilometer. Though individual parts must still be smaller than one kilometer (1000m; ~3280 feet; ~39,370 inches), you can assemble parts such that the overall size of the assembly exceeds one kilometer.
Mate References in Lightweight Assemblies

Mate references are now supported in lightweight assemblies. Previously, the component containing the mate reference needed to be resolved for the mate reference to work.

Motion Studies in Lightweight Assemblies

You can run motion studies for assemblies in lightweight mode. You do not have to resolve a large assembly before running a motion study.

SpeedPak

SpeedPak creates a simplified representation of an assembly without losing references. If you work with very large and complex assemblies, using SpeedPak can significantly improve performance while working in the assembly and its drawing. See SpeedPak on page 75.

Unloading Hidden Components

You can unload hidden components from memory but retain the effects of their mates.

To unload hidden components, right-click the assembly icon at the top of the FeatureManager design tree and select Unload Hidden Components. The components are unloaded from memory and are not visible, but the effects of their mates are retained. In SolidWorks 2008, you could use Quick view / Selective open while opening an assembly, to load only visible components, leaving hidden components unloaded. Now you can unload hidden components after the assembly is open.

Assembly Features in Parts

You can propagate assembly features into the parts they affect. Features you can propagate include:

- Hole Wizard holes
- Simple holes
- Extruded cuts
- Revolved cuts

If you pattern the features in the assembly, the pattern feature also propagates to the part file.

Select Propagate feature to parts in the Feature Scope section of the PropertyManager when you create the feature in the assembly. Otherwise, the feature appears only in the assembly and not in the part.

In the part, external references to the assembly feature are created, and the feature appears at the bottom of the part’s FeatureManager design tree. For sketch-based features, a derived sketch is created in the part as well.

You edit the feature in the context of the assembly. If you want to edit the feature from within the part document, you must first break the external references.

💡 In the part document, you can right-click the feature and select Make Independent to break the reference.
Bills of Materials in Assembly Documents

You can create bills of materials (BOMs) in assembly files. You no longer need to create a drawing first.

Create a BOM in an assembly or part by clicking Insert > Tables > Bill of Materials. After setting parameters in the PropertyManager, click in the graphics area to place the BOM.

<table>
<thead>
<tr>
<th>ITEM NO</th>
<th>PART NUMBER</th>
<th>QTY</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Housing</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Cover</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Outer Rotor</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>Inner Rotor</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>Shaft</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>Pin</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td>Gear</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>Retaining Ring</td>
<td>1</td>
</tr>
</tbody>
</table>

BOMs appear in the Tables folder in the FeatureManager design tree. The name of the configuration to which a BOM applies appears beside the BOM feature.

Working with Assembly BOMs

You can edit a BOM in the assembly just as you would in a drawing.

You can edit a BOM in a separate window. In the FeatureManager design tree, right-click the BOM and select Show Table in New Window. When you close the window, the BOM returns to the graphics area of the assembly.

You can right-click a BOM to:

- Print it
- Select Save As and export to these formats:
  - Template (.sldbomtbt)
  - Excel (.xls)
  - Text (.txt)
  - Comma-separated values (.csv)
  - Drawing interchange format (.dxf)
  - Drawing (.dwg)
  - eDrawings (.edrw)
  - Portable document format (.pdf)

After creating an assembly BOM and saving the assembly, you can insert the BOM into a referenced drawing. See Copying Assembly BOMs into Referenced Drawings on page 88.

The BOM in the drawing is not linked to the BOM in the assembly.

The balloon status column is not supported in BOMs in assembly files.
Clearance Verification

With Clearance Verification, you can check the clearance between selected components in assemblies. The software checks the minimum distance between the components and reports clearances that fail to meet the minimum acceptable clearance you specify.

You can select entire components or particular faces of components. You can check between just the selected components, or between selected components and the rest of the assembly.

To check clearance, click Clearance Verification (Assembly toolbar) or Tools > Clearance Verification. The tool works in a manner similar to Interference Detection. To display a clearance failure in the graphics area, select it in Results in the PropertyManager.

Hinge Mates

A hinge mate limits the movement between two components to one rotational degree of freedom. It has the same effect as adding a concentric mate plus a coincident mate. You can also limit the angular movement between the two components.

Advantages of hinge mates:

- When modeling, you need to apply only one mate, where otherwise you would have applied two.
- If you run an analysis (such as with SolidWorks Simulation), the reaction forces and results are associated with the hinge mate, not one particular concentric or coincident mate.

To add a hinge mate:

1. Open Assemblies\hinge_mate.sldasm.
2. Click Mate (Assembly toolbar).
3. In the PropertyManager, under Mechanical Mates, click Hinge.
4. Under Mate Selections:
   a) For Concentric Selections, select the two cylindrical faces as shown.

   ![Concentric Selections](image)

   b) For Coincident Selections, select the two planar faces as shown.
The two components align.

5. Select **Specify angle limits**.
6. Define the extents of the rotation:
   a) For **Angle Selections**, select the two faces as shown.
   b) For **Maximum Value**, enter 90.
   c) For **Minimum Value**, enter 0.
7. Click ✅ twice to apply the mate.

**Hinge** appears in the **Mates** folder in the FeatureManager design tree. The hinge mate allows the flap to rotate 90° about the pin.

**Sensors**

Sensors monitor selected properties of parts and assemblies and alert you when values deviate from the limits you specify.

**Sensor Types**

Sensor types include:

- **Mass Properties**. Monitors properties such as **Mass**, **Volume**, and **Surface Area**.
- **Measurement**. Monitors dimensions you select.
• **Interference Detection.** (Available in assemblies only.) Monitors the assembly for interferences between components you select.

• **Simulation Data.** (Available in parts and assemblies, for use in SolidWorks Simulation.) Monitors data such as *Stress, Strain, Displacement*, etc.

💡 For more information about **Simulation Data** sensors, see **Sensors** on page 112.

### Creating Sensors

To create a sensor, right-click the **Sensors** folder in the FeatureManager design tree, select **Add Sensor**, and set parameters in the PropertyManager. Optionally, you can set an alert to notify you immediately when the sensor value deviates from the limits you specify.

### Notifications

Notifications appear at specified intervals to notify you about:

• Sensors that have triggered alerts
• Sensors that are out of date

To change the notification intervals, right-click the **Sensors** folder in the FeatureManager design tree, select **Notifications**, and set parameters in the PropertyManager.

### SpeedPak

**SpeedPak** creates a simplified representation of an assembly without losing references. If you work with very large and complex assemblies, using SpeedPak can significantly improve performance while working in the assembly and its drawing.

Use **SpeedPak** when you want to insert a complex large assembly into a higher level assembly. A SpeedPak is essentially a subset of the parts and faces of an assembly, which you create in the ConfigurationManager. Unlike regular configurations, where you can simplify an assembly only by suppressing components, **SpeedPak** simplifies without suppressing. Therefore, you can substitute a SpeedPak for the full assembly in higher level assemblies without losing references. Because only a subset of the parts and faces is used, memory usage is reduced, which can increase performance of many operations.

### Creating a SpeedPak

📝 For simplicity, a small assembly is used in this example. However, improvements in assembly performance due to SpeedPak are most noticeable in very large and complex assemblies.

To create a SpeedPak:

1. Open `Assemblies\computer_assembly\power supply assembly.sldasm`.

2. On the ConfigurationManager tab, under **Configurations**, right-click **Default** and select **Add SpeedPak**.

3. In the PropertyManager:
   a) For **Faces to Include**, select the front, bottom, and back faces of the chassis.
b) For **Bodies to Include** 🍂, select the connector.

![assembly](image)

c) Click ✅.

A configuration named **Default_speedpak** is created as a child of **Default**.

4. Move the pointer over the assembly.
   In the region surrounding the pointer, only the faces and body you selected for the SpeedPak are visible.

![assembly](image)

Assembly without pointer  Assembly with pointer

To see the behavior described in step 4, make sure the driver for your graphics card is up to date. See [http://www.solidworks.com/pages/services/VideoCardTesting.html](http://www.solidworks.com/pages/services/VideoCardTesting.html).
5. Click the FeatureManager tab.
   No components appear in the FeatureManager design tree. Note the SpeedPak assembly icon at the top of the tree.

6. Save the assembly.

**Inserting a SpeedPak**

To insert a SpeedPak:

1. Open `Assemblies\computer_assembly\computer01.sldasm`.
2. Click **Insert > Component > Existing Part/Assembly**.
3. In the PropertyManager:
   a) Under **Part/Assembly to Insert**, select `power supply assembly`.
   b) Click anywhere in the graphics area to insert the assembly.

   In the region surrounding the pointer, only the faces and body you selected for the SpeedPak are visible. They are the only items you can select for operations such as mating.

When you use SpeedPak configurations in drawings, you can only dimension to edges included in the SpeedPak.
This chapter includes the following topics:

- **General**
- **Design Library for Motion Elements**
- **Redundant Constraint Force Results**
- **Motion for Layout Sketches**
- **Mates**

### General

**Name Changes**

The COSMOSMotion™ add-in name is changed to SolidWorks Motion. Names of study type are also changed.

<table>
<thead>
<tr>
<th>Old Study Type Name</th>
<th>New Study Type Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>COSMOSMotion</td>
<td>Motion Analysis</td>
</tr>
<tr>
<td>Physical Simulation</td>
<td>Basic Motion</td>
</tr>
<tr>
<td>Assembly Motion</td>
<td>Animation</td>
</tr>
</tbody>
</table>

These name changes affect the corresponding property headings in the **Motion Study Properties** PropertyManager.

**Lightweight Assembly Support**

You can run motion studies for assemblies in lightweight mode. You do not have to resolve a large assembly before running a motion study.

**Configuration-specific Motion Studies**

You can calculate motion study results for different model configurations.

To obtain results for two configurations:

1. Calculate a motion study for one configuration and plot the results.
2. Switch to the other configuration.
3. Click **Play from Start** to update the configuration-specific results.

### Design Library for Motion Elements

You can save motion elements such as springs, motors, or force specifications for reuse in other models.
Add motion elements to the Design Library as you would add other items. All motion elements in the Design Library are saved with the .sldsimfvt extension.

While in any motion study, drag saved motion elements from the Design Library to your model.

Redundant Constraint Force Results

As in previous releases, a Motion Analysis study eliminates redundant constraints when calculating motion. This results in a calculation of zero force at the mate locations of the affected parts. For models with redundant constraints due to mates, you can have SolidWorks Motion automatically replace these mates with bushings. Forces are then calculated at the locations of the redundant mates.

These redundant constraint options available in previous releases are now obsolete:

- Make all mates flexible.
- Replace redundant constraints with bushings, available by clicking Advanced Options.

To address redundant constraints, now you can select Replace redundant mates with bushings under Motion Analysis in the Motion Studies Properties PropertyManager before running the study. This leads to better force results in most cases.

You can edit the overall bushing stiffness and damping values used in the motion study by clicking Bushing Parameters from the Motion Study Properties PropertyManager.

Motion for Layout Sketches

You can now run Animation and Motion Analysis motion studies for layout sketch mechanisms you create from sketch blocks.

Motion Analysis studies require values for the mass, center of mass, and moments of inertia for each block in the layout sketch. Estimated values for mass and moments of inertia are assigned to each block, based on a uniform steel block. The default value for the center of mass is at the center of the block.

For each block in the layout sketch, you can modify the component mass properties by editing Mass Properties in the Block PropertyManager before running a Motion Analysis study.

You cannot edit the mass properties for a layout sketch motion study unless you select Motion Analysis for the motion study type.
Example: Layout Sketch for a Crane

Run a **Motion Analysis** study on a two-dimensional layout sketch:

1. **Open** Motion Studies\Crane_Layout.sldasm and select the **Motion Study** tab.

   ![Layout Sketch for a Crane](image)

   The layout sketch consists of connected blocks. The blocks are listed in the FeatureManager design tree and in the MotionManager tree.

2. Click the force in the MotionManager design tree.

   The force is applied at the piston.

3. Click **Layout** (Layout Tools toolbar).

4. Select the upper arm block in the layout sketch in the graphics area.

5. Scroll to **Mass Properties** in the upper arm **Block** PropertyManager.

   The default mass value is estimated. You can edit the mass, change the center of mass location, or edit moments of inertia.

6. Click ✓ and ⊞ to close the layout sketch.

7. Click **Play from Start** to view the motion.

**Mates**

**Path Mates**

You can now include path mates in **Motion Analysis** studies.

To constrain assembly component motion to a path:

1. Select **Insert > Mate**.
2. Define a path mate for components.
3. Select the Motion Study tab, and select **Motion Analysis** for **Type of Study**.
4. Include motion study elements as necessary.

   You must include a **Motor**, a **Force**, or **Gravity** to force the motion.

5. Run the study.
Example: Path Mate Motion Study with Gravity

1. Open `Motion Studies\MazeGame.sldasm`.
2. Select the **Motion Study** tab.
3. Click **Play from Start**.

Game at the start of the study:
- The path mate follows a path along the channels defined by the maze.
- The ball, forced by gravity, is set to follow the path defined by the path mate.

**Mate Location Points**

SolidWorks Motion studies use mate location points to determine how parts move in relation to each other. You can now modify the mate location used for motion studies.

You can override default location points by selecting **Mate location** from the **Analysis** tab of the **Mate** PropertyManager.

**Specifying the Mate Location**

To modify the mate location:

1. Select **Insert > Mate** to create a new mate or edit a selected mate.
2. Select the **Analysis** tab of the **Mate** PropertyManager.
3. Select the **Mate location** field and select a point on the model for the mate location.

   The mate location is always a point. If you select another type of entity such as a face for the mate location, the mate location is at the center of the selected entity.

4. Click ✅.
**Motion Study-specific Mates**

Motion study-specific mates are mates you create for a motion study that are independent of the assembly model mates. Using the new motion study-specific mates, you can now create multiple motion studies to analyze model motion with different mates without changing the model.

To create motion study-specific mates:

1. Select a motion study.
2. Add mates to the assembly from the motion study.

ียว Motion study-specific mates are listed only on the **MotionManager** design tree. The string *Local* prefaces the name of motion study-specific mates.

To see that the motion study-specific mates are not part of the assembly model, view the assembly mates from the **Model** tab.
Example: Working with Study-specific Mates

The model in this example includes four motion studies.

Each motion study:
- Starts with a wrench assembly.
- Adds a distance mate to the wrench screw within the motion study. The distance mate determines how far the screw can turn.
- Adds a force at the wrench handle.

Each motion study uses a different distance mate. Calculate the motion for each study to find the distance required to make the wrench close:

1. Open Motion Studies\Wrench.sldasm

2. Select the MotionStudy2_Distance=0.6in motion study.
3. Expand the mates in the FeatureManager design tree.

These original model mates do not include a distance mate.

4. Expand the mates in the MotionManager design tree.

Notice the distance mate LocalDistance7, defining how far the screw can turn to adjust the wrench handle and jaw positions as you force the handle.

5. Right-click the distance mate and select Edit Feature to view the distance mate parameters.

For this study, the mate distance is set to 0.6 inch. This distance mate is not part of the original assembly mate group and is relevant only to this motion study.

6. Click Play from Start to view the motion.

The wrench does not close all the way.

7. Select the other motion study tabs to view this experiment with different distance mate values. Each study has a different mate
distance value, but none of the studies change the original model mates.

8. Calculate the final motion study with a mate distance of 1.0 inch to see the wrench close.
This chapter includes the following topics:

- Customized Drafting Standards
- Bills of Materials (BOMs)
- Detail Positioning
- Print Options for Drawings
- Title Blocks in Drawing Sheets
- Favorites are Renamed to Style
- Format Painter
- Detailing for Sketch Slots
- General

Customized Drafting Standards

Detailing document properties include specifications for dimensions, annotations, and tables. A drafting standard includes a set of detailing document properties that you can use with multiple drawings. You can now create and customize drafting standards for a drawing document.

You can:
- Save drafting standards to a file, archive them, and send them to others.
- Import drafting standards from a saved standards file.
- Save custom standard settings to drawing templates.
- Rename, copy, or delete custom standards.

You can create customized drafting standards by clicking **Options** (Standard toolbar) and then selecting **Document Properties**.

Custom settings for document properties include:
- Base detail and overall drafting standards
- Customized drafting settings for each detail type
- Document-level layer defaults
- Custom leader and frame style and thickness
- Preview images for each detail type

The overall drafting standard is saved under a modified name to prevent overwriting a fixed standard when you:
- Select one of the fixed overall drafting standards such as ANSI or ISO.
- Modify a detailing document property.
Customizing the Drafting Standard

For this example, the drafting standard requirements for your company are:

- Overall drafting standard: ANSI
- Base standard for weld symbols: GB
- Leader thickness for all annotations and dimensions: 0.20mm

To set up these requirements:

1. Click **Options** (Standard toolbar).
2. From the **Document Properties** tab, select **Drafting Standard**.
3. Select **ANSI** for the **Overall Drafting Standard**.
4. Select **Annotations > Weld Symbols** and select **GB** for the **Base weld symbol standard**.
5. For each annotation and dimension type, select **Custom Size** for **Leader Thickness** and type 0.20mm.
6. Select **Drafting Standard** and click **Save to External File**.
7. After selecting the necessary directory, click **Save** to save the .sldstd standard file.
8. Click **OK**.

All users can refer to a saved standard by loading it. To load a saved standard, select **Drafting Standard** and click **Load**.

Overall Drafting Standards and Base Detail Standards

You can now specify an overall drafting standard that provides defaults for all detailing options. Overall drafting standards apply to all detail settings unless you derive settings for a particular set of details from another base detail standard.

For example, all detail settings derive defaults from the ANSI standard when you set the **Overall drafting standard** to ANSI. Diameter dimensions derive default settings from the ISO standard when you set the **Base diameter dimension standard** to ISO.

To select an overall standard:

1. Click **Options** (Standard toolbar).
2. Select **Drafting Standard** from the **Document Properties** tab.
3. Select an overall standard.

You can also change, load, or save the overall drafting standard.

To customize a base standard for a selected detail:

1. Click **Options** (Standard toolbar).
2. Select the detail, such as **Annotations > Balloons**, from the **Document Properties** tab.
3. Select a base standard for the detail, for example, the **Base balloons standard**.
A base detail standard supersedes overall drafting standard settings for the selected
detail.

**Document Layer Defaults**
You can now customize the document-level layer settings for each type of detail.
After creating layers for a drawing, you can select a different layer setting for each
dimension, annotation, table, and view label detail. For example, create two layers and
assign one layer to diameter dimensions and the other to surface finish annotations. By
setting layers for details at the document level, you do not have to switch layers in the
drawing to apply custom layers.

After you assign a document-level layer to a detail type, the detail is added to the
selected layer when you add that type of detail to the drawing.

To set document-level layer defaults for a detail:
1. Create layers for a drawing in SolidWorks.
2. Click **Options** (Standard toolbar).
3. Select a detail, such as **Dimensions > Chamfer**, from the **Document Properties**
tab.
4. Under **Layer**, select a layer for the detail.

You can assign document-level layers to dimensions, annotations, view labels, and tables.

**Custom Line Thickness and Style**
For each drawing dimension and annotation type, you can now specify document-level
line thickness and style. You can override document-level line thickness and style settings
for individual annotation and dimension elements when you create or edit them.

To assign line thickness or style:
1. Click **Options** (Standard toolbar) and select the **Document Properties** tab.
2. Set style and thickness for the following:
   - All dimension leaders
   - All annotation leaders
   - Frames for geometric tolerances, balloons, and datums

<table>
<thead>
<tr>
<th>Style</th>
<th>Thickness</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Style Image]</td>
<td>![Thickness Image]</td>
</tr>
</tbody>
</table>
When setting line thickness, you can customize the thickness by selecting **Custom size** from the thickness list and typing a value.

**Overriding Document-Level Line Thickness and Style**

You can override document-level leader and frame thickness and style settings for individual annotations or dimensions in a drawing. To override these settings, select the entity and clear **Use document display** in the PropertyManager.

**Detailing Previews for Document Properties**

Preview images now update as you modify document property detail settings.

<table>
<thead>
<tr>
<th>Preview Selection</th>
<th>Preview Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diameter dimension text aligned with diameter leader</td>
<td><img src="image" alt="Diameter Dimension Preview" /></td>
</tr>
<tr>
<td>Diameter dimension text aligned horizontally</td>
<td><img src="image" alt="Diameter Dimension Preview" /></td>
</tr>
</tbody>
</table>

All detail settings affect the preview image. For example, if you change the dimension font, the preview image font changes accordingly.

To view detail preview images:

1. Click **Options** (Standard toolbar).
2. Select a detail from the **Document Properties** tab.

**Bills of Materials (BOMs)**

**Copying Assembly BOMs into Referenced Drawings**

You can create bills of materials (BOMs) in assembly files and multibody part files. You no longer need to create a drawing first. See **Bills of Materials in Assembly Documents** on page 72. After creating a BOM in an assembly and saving the assembly, you can insert the BOM into a referenced drawing.

To insert a BOM saved with an assembly into a referenced drawing:

1. Select **Insert > Tables > Bill of Materials.**
2. In BOM Options, select **Copy existing table**.
3. Select an assembly BOM from the list.

**Restructuring BOMs**

You can now restructure assembly components in a BOM table without affecting the assembly structure:

- Dissolve subassemblies or weldments.
- Combine all items that are identical to a selected item, such as parts or weldments in the BOM.
- Drag items from one cell in the Assembly Structure column to another to combine like items or re-arrange the hierarchy.
- Display detailed weldment cut lists.

📝 To restore restructured items, right-click a modified assembly item and select **Restore Restructured Components**.

**Dissolving Subassemblies or Weldments**

You can remove individual parent components within the indented hierarchy of a BOM while retaining child components by dissolving items in the BOM. Right-click cells in the BOM Assembly Structure column to dissolve selected subassemblies or weldments, removing them from the BOM display.

In the indented display of BOM components, right-click the first subassembly in the BOM Assembly Structure column and select **Dissolve**.

The first subassembly is dissolved. Its parts move to the bottom of the Assembly Structure column.

**Combining Like Items**

Right-click a cell in the BOM Assembly Structure column to combine the item in the selected cell with all identical items in the BOM.
In the indented display of BOM components, right-click a washer in the first subassembly, and select **Combine Identical Components**.

All identical washers are combined with the selected washer. Item numbers and quantities are updated.

To separate combined items, right-click a combined item and clear **Combine Identical Components**.

**Dragging Items to Restructure the BOM**

You can combine like items or rearrange items by dragging components and subassemblies in the BOM Assembly Structure column.

You can drag:

- Weldment bodies to weldment bodies or parts
- Parts or assemblies to parts or bodies
- Parts, bodies, or assemblies to assemblies

**Detailed Weldment Cut Lists in BOMs**

You can now include detailed weldment cut lists for parts and assemblies in indented BOMs. A single BOM can contain multiple weldment cut lists. A single drawing with multiple views can contain multiple BOMs. Each BOM can include different weldment cut lists.

To display BOMs with detailed cut lists:

1. Select **Insert > Tables > Bill of Materials**.
2. Select **Indented**, and then select **Detailed cut list** for **BOM Type**.
3. To display cut length information in the **Length** column of the BOM, select `bom-weldment cut list.sldbomtbt` for **Table Template**.

The weldment cut information is displayed in the **Description** column of the BOM.

You can display the detailed cut list for indented type BOMs by right-clicking the BOM table and selecting **Detailed Cut List**.

When you dissolve weldments that include a detailed cut list, the detailed cut list is retained in the table.

**Item Numbering**

You can now select flat numbering, detailed numbering, or no numbers for items in indented BOMs. Select item numbering in the **Bill of Materials** PropertyManager.
These new numbering options for indented assemblies replace the now obsolete Show numbering option.

**Detail Positioning**

**Positioning Notes**
You can now position notes in the following ways:

- Specify the position of a selected note from the Note PropertyManager or select Display on the screen from Parameters.
  
  
- After selecting Move Entities (Sketch toolbar), click the note to select it, and then click the final position for the note. You can also specify the change in note coordinates, or use snaps to snap a note to a new position.

- Drag notes around.

- From the Text Format section of the Note PropertyManager, set the vertical alignment of note text.

- Right-click a note and select Snap to Rectangle Center to use a rectangle to position a note.

**Specifying Note Position from X-Y Coordinates**
To specify note position from its on-screen X-Y coordinates:

1. Select a note.
2. From the Note PropertyManager, select Display on the screen from Parameters.

   Coordinate fields appear in the graphics area.

3. Modify the X-Y coordinates for the selected note in the X and Y fields that appear.
4. Click away from the note to close the coordinate fields.

   When you select Display on the screen in the Note PropertyManager after selecting a note, X-Y coordinate fields appear on the drawing for all notes you subsequently select.
**Attaching Dimension Extension Lines**

You can now attach dimension extension lines to sketch dimensions or drawing reference dimensions:

- Move dimension extension line endpoints to other vertices or sketch entities in drawings by single-clicking, moving the mouse to the target location, and clicking again.
- Use the quick snap options available when you select and then right-click a dimension extension line endpoint.

You cannot attach feature dimensions using either method.

**Jogging Extension Lines**

You can now right-click a linear dimension extension line and select *Display Options > Jog* to place a jog in the line.

To remove a jog from a selected dimension extension line, right-click the line and clear *Display Options > Jog*.

**Dimension Leader Control for Same-sized Features**

You can now move radial, diameter, or chamfer dimension leaders, or hole callout leaders among same-sized features in a drawing view.

To move the dimension and hole callout leader endpoints for common features, drag leader endpoints from one feature to another.

You cannot drag dimension leaders for like features across views.
Example: Like Fillets and Holes

1. Open `Detailing\PARTWITHSAMEFEATURES.slddrw`.
2. For the bottom view, select the fillet dimension on the left and drag the dimension leader to the same-sized fillet on the right.

![Diagram of fillets and holes]

When you drag a dimension extension line to a feature of the same size, the feature is highlighted as you hover over it.

3. For the front view, select the hole callout and drag the leader to another hole.

![Diagram of hole callout and leader]
Multiple Jogs for Dimensions and Callouts

You can now add multiple jogs to dimension and callout leaders from Leaders tab of the Dimension PropertyManager. You can also add jogs as you place a dimension or callout by right-clicking and selecting Add jog point. Drag jog points to create the jog after inserting the jog point.

You can add multi-jog leaders to hole callouts and to these dimension types:
- Diameter
- Radial
- Chamfer

Print Options for Drawings

The Print dialog box options have been modified. You can now:
- Print zoomed selections.
- Print an active drawing sheet for multi-sheet drawings.
- Change the new document-level printed line thickness settings while printing by clicking Line Thickness.

In addition, the drawing document properties now control the print thickness for lines. To access the printed line thickness settings while printing, from the Print dialog box, click Line Thickness.

Printing Drawings from Zoomed Selections

To print from a zoomed selection:
1. Zoom in on a portion of a drawing.
2. Select File > Print.
3. Select Current screen image on the Print dialog box.

Custom Line Thickness for Print Settings

You can now set the line thickness used in print settings for drawing documents and templates from the drawing document properties.

To set the thickness of lines printed from drawings:
1. Click **Options** (Standard toolbar).
2. Select **Line Thickness** from the **Document Properties** tab.
3. Set the print line thickness for any displayed thickness setting.

---

You can modify the printed line thickness for a document when you print by clicking **Line Thickness** in the **Print** dialog box.

### Title Blocks in Drawing Sheets

**Title Block Management**

You can now select the notes in title blocks that can be entered and changed in drawings.

When defining a title block you can:

- Specify which fields are editable by template users.
- Specify a hotspot area that users click to enter title block data.

**Defining or Editing Title Blocks**

To define or edit a title block for use in templates:

1. Open a drawing sheet, right-click the sheet format in the FeatureManager design tree, and select **Define Title Block**.

   - If you have already defined the title block, select **Edit Title Block**.

2. Drag a corner to resize the rectangle laid over the title block area.
This rectangle defines the hotspot that users of the drawing click to enter data in the title block.

You can select a hotspot of any size.

3. Select notes in the title block.
The selected notes specify the title block data that users can enter into this drawing or into a drawing created from a template based on this drawing.

4. Click arrows \( \downarrow \) or \( \uparrow \) to reorder selected items in the **Title Block Notes** list in the **Title Block** PropertyManager.
The note order determines the order in which notes are presented to template users when they tab through the fields.

5. To aid users, type informational text for each selected note in the **Tooltip** field.

6. Click \( \checkmark \).

7. Save the drawing as a template.

**Entering Title Block Data**

To enter title block data in a drawing:

1. Right-click the **Sheet Format > Title Block** in the FeatureManager design tree, and select **Enter Title Block Data**.
   Data fields that you can edit are highlighted.

2. Enter text for each data field.
   
   Hover over an editable text field to view information about what text to enter.

3. Click \( \checkmark \).
Favorites are Renamed to Style

Detailing Favorites is now called Style.

Save detailing styles under Style in the following PropertyManagers:

- Note
- Dimension
- Weld Symbol
- Surface Finish
- Datum Feature *
- Datum Target *
- Balloon *
- Auto Balloon
- Stacked Balloon
- Center Mark *

* indicates that styles for the detail are new.

Format Painter

The Format Painter tool has been moved from SolidWorks Utilities into core SolidWorks. All current functionality from SolidWorks Utilities is supported. Use Format Painter to paint the properties or styles used in one annotation to another.

Format Painter supports:

- All annotation properties, such as font, leader line style, line thickness, and layer (except for centerlines and center marks)
- Component line fonts in drawings
- Crosshatch

Using Format Painter

In this drawing, you paint the bilateral tolerated dimension format to the other dimension.

To use Format Painter:

1. Click Format Painter (Tools toolbar) or Tools > Format Painter.
2. Select the source dimension for the format. The dimension changes color.
3. Select the destination dimension to paint with the source dimension format. The destination dimension changes to a bilateral format and applies the same tolerance values.

If the destination dimension already has a tolerance, Format Painter applies the bilateral format but does not override the tolerance values.

Source with bilateral tolerance values  Format Painter paints the bilateral format to the destination but leaves the existing .009 tolerance value intact

4. Click ✓ to close the PropertyManager.

**Detailing for Sketch Slots**

You can now insert center marks in slots, include slots in hole tables, and display hole callouts for straight slots.

See Slot Sketch Entity on page 31.
Center Marks in Slots

End-centered center marks for a straight slot  Slot-centered center mark for an arc slot  End-centered center marks for an arc slot

To insert center marks into slots whenever you create drawing views:

1. Click **Options** (Standard toolbar).
2. Select the **Document Properties** tab.
3. Select the **Detailing** page, and select the **Center marks - slots** auto-insert option.
4. Select the **Centerline/Centre Mark** page, and select the slot center mark placement options.

The slot center mark placement options affect all center marks you place in slots, not just the ones SolidWorks places in drawing views automatically.

To manually place a center mark in a slot, select **Slot center marks** for **Options** in the **Center Mark** PropertyManager.

**Slots in Hole Tables**

You can now include slots in hole tables:

- Slot center location appears in the **XLOC** and **YLOC** columns.
- Slot dimensions for straight slots appear in the **SIZE** column.

**Hole Callouts for Slots**

You can now apply hole callouts to straight slots. The slot dimensions appear in the callout.

**General**

**Cancelling Long Operations for Drawings**

You can press **Esc** to interrupt long operations such as drawing view creation or rebuild.

You can:

- Cancel a long drawing rebuild operation to edit the drawing further before completely rebuilding.
- Cancel long drawing view creation operations if you do not require the full drawing view.

**Exporting Tables to Excel**

You can now export tables to all Excel formats, including .xlsx.
Opening Multi-sheet Drawings in Quick View

You can now open multi-sheet drawings quickly by viewing most sheets in Quick view, which is a read-only mode that provides a simplified drawing representation. You cannot edit sheets in Quick view. Opening sheets in Quick view can save time when opening complex drawings.

To open selected sheets of a multi-sheet drawing in Quick view:

1. Click File > Open.
2. Browse your computer to locate a multi-sheet drawing, and click to select it.
   The options for multiple sheet drawings appear.

   If you double-click the drawing file, the file opens before you can set the options.

3. For Select sheets to load, select:
   • Selected:
     1. Select the sheet to be active when loaded.
     2. Press Ctrl + select one or more other sheets to fully load.
   • None. Select the sheet to be active when opened in Quick view.
      An asterisk appears next to the active sheet.

4. Click Open.

   You must convert multi-sheet drawings from previous versions of SolidWorks to SolidWorks 2009 before you can open sheets in Quick view.

   To fully load a drawing sheet that is opened in Quick view, right-click the Sheet tab and select Load Sheet.

Document Properties Options Reorganization

With a drawing document open:

1. Click Options (Standard toolbar).
2. Select the Document Properties tab.

   The drawing document properties have been reorganized so that you can now set:
   • Dimension details for each dimension type
   • Annotation details for each annotation type
   • Table details for each table type on a separate page
   • View label details for each view label type on a separate page

   For more information, see Customized Drafting Standards on page 85.

Lightweight Assembly Drawings

With some exceptions, assembly drawings are now loaded as lightweight.

The Lightweight option in the drawings Open dialog box is now obsolete.
This chapter includes the following topics:

- Intersect Line Features
- ISO Standards Support
- Orientation Constraints
- Redundant Dimensions
- Tangency Constraints

**Intersect Line Features**

The **Automatic Dimension Scheme** tool dimensions intersect line features automatically. Previously you had to dimension intersect lines manually. You also have the option to use angle dimensions.

DimXpert for parts creates intersect line features for these cases:

- Between non-perpendicular planes that share a common edge
- Between non-perpendicular planes that have an intermediate fillet or chamfer
Within the features of a pocket feature, including non-perpendicular planes that have an intermediate fillet or chamfer feature.

You can have the Auto Dimension Scheme tool apply angle dimensions to planes at an angle to the datum feature. To enable angle dimensions, open a part, click Options > Document Properties > DimXpert > Location Dimension and select Locate planes with angle dimensions under Auto dimension scheme.

ISO Standards Support

DimXpert for parts now supports ISO standards 1101 and 16792, as well as ANSI. PropertyManagers and the Display Options dialog box are modified. ANSI dimensioning and tolerancing is also enhanced.

Document Properties > DimXpert > Display Options contains these new display options:

- Datum gtol attachment
- Gtol linear dimension attachment
- Hole callouts

The following examples illustrate the new methods for placing and attaching annotations. Although some examples show only ANSI or ISO, the methods can apply to both standards.
**Dimensions**
You can dimension outside diameters and spheres using directed leaders (ANSI) and dimensions (ISO) that are attached to the surface of the feature.

![ANSI](image1.png)  ![ISO](image2.png)

**Hole Callouts**
You can break and display hole callouts as separate dimensions or combine them. Select the dimension, right-click, and select **Break Callout Dimension** or **Combine Callout Dimension**. Set the defaults under **Hole callouts** in the **Display Options** dialog box.

![Current method (ANSI)](image3.png)  ![New method (ISO)](image4.png)

**Datums**
New attachment options include directed leaders and radial and linear dimensions.

![ANSI](image5.png)  ![ISO](image6.png)
You can attach a datum symbol to the surface of the feature, the dimension, or the feature control frame. Click **Surface** or **Gtol** under **Leader** in the **Datum Feature** PropertyManager. Set the defaults under **Datum Gtol attachment** in the **Display Options** dialog box.

Current method (ANSI)  
New method (ISO)

You can add notes and symbols to datum feature symbols. Under **Text**, type notes to add to the datum feature. Click **More** to add symbols.

**Geometric Tolerances**

New attachment options include radial and linear dimensions and directed leaders.

ANSI  
ISO
You can combine and attach the feature control frame with the size limits as shown on the left, or attach the feature control frame and size limits separately as shown on the right. Set the defaults under **Gtol linear dimension attachment** in the **Display Options** dialog box.

![Current method (ANSI)](image1)
![New method (ISO)](image2)

You can attach the feature control frame to the size limits or to the surface using a directed leader. Click **Directed Leader** or **Dimension** under **Leader** in the **Geometric Tolerance** PropertyManager.

![ANSI](image3)
![ISO](image4)

You can add notes and symbols to feature symbols. Under **Text**, type notes to add to the feature. Click **More** to add symbols.

**Orientation Constraints**

DimXpert for parts recognizes a feature's implied vertical and horizontal constraints when checking its tolerance status.
This part was not considered fully constrained. DimXpert does not recognize that the top plane is horizontal.

The top plane is fully constrained by an intersect line and a horizontal constraint.

**Redundant Dimensions**

DimXpert for parts has enhanced its handling of duplicate dimensions and tolerances. You can now combine or keep duplicate size dimensions in addition to location dimensions. Automatic dimensioning now combines dimensions where appropriate.

**Automatic Combination**

Depending on how you model a part, the Automatic Dimension Scheme tool (ADS) creates separate size dimensions and tolerances even when they can be dimensioned as one.

To have the ADS tool automatically combine duplicate size dimensions and tolerances, click **Options** > **Document Properties** > **DimXpert** > **Display Options** and select **Eliminate duplicates** under **Redundant dimensions and tolerances**.

The ADS tool then automatically combines these entities:
- Plus/Minus size dimensions
- Size dimensions with geometric tolerances
- Geometric tolerances
Manual Combination

To combine the same types of duplicates manually, Ctrl + select the dimensions in the graphics area, right-click, and select Combine dimensions or Combine Gtol.

 Compatibility restrictions apply. For example, to combine size dimensions, dimensions must be the same size, have the same tolerance, and be linked to the same feature type.

Tangency Constraints

DimXpert for parts now considers the effects tangencies between planes and cylinders have on dimensioning, tolerances, and constraint status. All DimXpert for part functions support and consider tangency constraints.

Tangency constraints exist where a plane and cylinder are adjacent.
Cylinder type features include boss, cylinder, and simple hole.

The Tangency annotation type appears in the DimXpertManager under the tolerated feature.

Tangency annotation types have an origin feature and a tolerance feature.

Tangency constraints are supported for pocket features. They are not created for fillet, notch, or slot features, which have a built-in implied tangency.

Show Tolerance Status

The angled plane and two adjacent tangent cylinders are under constrained when you click Show Tolerance Status.

The angled plane and adjacent tangent cylinders are fully constrained.
This chapter includes the following topics:

- Product Name Changes
- Simulation Workflow
- Simulation Studies
- Assemblies
- Connectors
- Mesh
- Contact and Bonding
- Result Viewing

Product Name Changes

The COSMOS products have been renamed.

<table>
<thead>
<tr>
<th>Previous Name</th>
<th>New Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>COSMOSWorks</td>
<td>SolidWorks Simulation</td>
</tr>
<tr>
<td>COSMOSWorks Designer</td>
<td>SolidWorks Simulation</td>
</tr>
<tr>
<td>COSMOSWorks Professional</td>
<td>SolidWorks Simulation Professional</td>
</tr>
<tr>
<td>COSMOSWorks Advanced Professional</td>
<td>SolidWorks Simulation Premium</td>
</tr>
<tr>
<td>COSMOSXpress</td>
<td>SolidWorks SimulationXpress</td>
</tr>
<tr>
<td>COSMOS FloXpress</td>
<td>SolidWorks FloXpress</td>
</tr>
<tr>
<td>COSMOSFloWorks PE</td>
<td>SolidWorks Flow Simulation</td>
</tr>
<tr>
<td>COSMOSFloWorks STD</td>
<td>SolidWorks Flow Simulation</td>
</tr>
<tr>
<td>COSMOSFloWorks</td>
<td>SolidWorks Flow Simulation</td>
</tr>
<tr>
<td>COSMOSMotion</td>
<td>SolidWorks Motion</td>
</tr>
</tbody>
</table>

The enhancements are available in SolidWorks® Simulation and higher unless otherwise noted. Enhancements marked with (Professional) are available in SolidWorks® Simulation Professional and higher. Enhancements marked with (Premium) are available in SolidWorks® Simulation Premium.
Simulation Workflow

User Interface
Major changes to the SolidWorks Simulation workflow and user interface have been implemented to achieve a tighter integration with the SolidWorks workflow and improve the overall user experience.

- SolidWorks Simulation toolbars are merged into one main toolbar. Only the toolbar buttons that relate to the active study type are highlighted.

- The Simulation CommandManager is study-sensitive and provides access to all commands related to the active study and the document. It can be customized independently for each study type.

- Restraint and load definitions are reorganized in the CommandManager. Restraint definitions are grouped under **Fixtures**, load definitions are grouped under **External Loads**, and thermal loads are grouped under **Thermal Loads**. Connector and contact definitions are all grouped under **Connections**.

- Simulation studies appear as tabs under the graphics area.
• Only the active study appears in the Simulation study tree. In earlier releases, all studies appeared in the AnalysisManager tree.

• The Loads/Restraints folder has been removed from the Simulation study tree and the specific load or restraint definitions appear in their External Loads or Fixtures folders. The Contacts/Gaps folder has been removed from the Simulation study tree and the contact definitions now appear in the Connections folder.

• Load, restraint, and connector objects applied to a body are shown under the body icon in the Simulation study tree.

• Each Simulation study tab displays information specific to the study type. For example, a static study lists Fixtures, External Loads, and Mesh, while an optimization study lists Objective, Design Variables, and Constraints. The Parameters, Design Scenario and Results folders appear in the Simulation study tree only if at least one object of that type exists in the study; otherwise, these folders are hidden.

• PropertyManagers have been redesigned to show by default the most commonly used options under the Standard group box and the less frequently used options under Advanced.

• A new Split tab is added to the Fixtures, External Loads, and Connectors PropertyManagers. The Split tab allows the creation of split faces within the PropertyManager. You can split a selected face of a solid geometry by creating a sketch and projecting it on the face, or by intersecting other faces with the selected one. Use the Split tool to apply features to the desired portions of faces.

• When you apply a load, restraint, or connector to a valid geometry, you can preview the object symbol in the graphics area by hovering over the selected geometry. You do not have to click to display the object symbol to appear.

• You can double-click a fixture or load symbol in the graphics area to display the corresponding PropertyManager.
• All applicable SolidWorks entities are accepted as selections. For example, cylindrical faces, axes, and sketch lines are accepted where a linear direction is needed.

• In the Gravity PropertyManager, the default direction is selected as normal to the Bottom view orientation plane (negative Y direction). You can add additional gravity components under the Advanced group box.

• The Connectors PropertyManager now has a message window with tips for each connector type.

Managing Simulation Studies

Create a study

• Click New Study button (Simulation toolbar), or
• Click Simulation, Study, or
• Right-click under the graphics area and select Create New Simulation Study.

Activate a study

Click its tab. The Simulation study tree appears.

Delete a study

Right-click its tab and select Delete.

Rename a study

• Double-click its tab and type a new name, or
• Right-click its tab and select Rename.

Duplicate a study

Right-click its tab and select Duplicate. Specify a name and a configuration for the duplicate study.

Copy features from Study A to Study B

Activate Study A, select the desired features in the Study A tree, and drag them to the Study B tab.

The mesh type has been removed from the Simulation study definition. See Mesh Selection on page 126.
General

- The magnifying glass feature is supported for Simulation studies. Press G to invoke the magnifying glass. See Using the Magnifying Glass on page 17.
- When the program detects large displacement in static studies, the solver issues a message that allows you to proceed with the small displacement solution, or automatically activate the large displacement option and run. If you click Yes, the program sets the large displacement option on and restarts the solver automatically. In the Static dialog box, the Large displacement flag is selected.
- (Professional) The Sparse solver is enhanced for 64-bit machines to solve large models by optimizing memory allocation for frequency and buckling studies.
- When you run one or multiple Simulation studies, they now run as background processes. Right-click the study and select Run. Simulation continues to run in the background after the SolidWorks session is ended. When the simulation completes, results are stored in the designated directory.

To run multiple studies, click the down arrow on Run, and select Run All Studies.

- Simulation API Help now supports connectors.

Simulation Studies

Simulation Advisor
An improved version of Analysis Advisor, called Simulation Advisor, helps you:
- Determine the proper study types and create them automatically
- Define internal interactions between various bodies in the model as well as external interactions between the model and the environment
- Assess the safety, including possibilities of failure due to fatigue
- Optimize the model
- Interpret results

The Simulation Advisor drives the interface by starting the appropriate PropertyManagers and includes links to online help topics for more information. Simulation Advisor works with the Simulation user interface and opens PropertyManagers when you select specific options. For example, Simulation Advisor can help you create the proper study automatically.

Sensors
Simulation sensors are integrated with SolidWorks. The new sensors definition allows tracking of Simulation results across multiple studies. Simulation sensors now provide visual and sound alerts when tracked values exceed pre-defined threshold limits.
- Sensors for tracking Simulation data are now part of the SolidWorks Sensors PropertyManager defined in the FeatureManager design tree. To add a sensor, right-click Sensors in the FeatureManager design tree and select Add Sensor.
- For documents with multiple studies, sensor entities are updated automatically to show results of the active study.
• You can set a sound alarm notification to warn you when data values are equal to, greater than, or less than a threshold limit. In the Sensors PropertyManager, check Alarm and set the notification criteria.

• Sensors can now track factor of safety data for connectors in addition to stress, strain, displacement, connector forces, free body forces, thermal results, velocity, and acceleration. Trend tracker graphs are also defined as sensor objects. Sensor objects are listed under the Sensors folder in the FeatureManager design tree.

• You can define Workflow Sensitive sensors on vertices or on reference points where you want to graph results from transient studies such as nonlinear, linear dynamic, drop test, and transient thermal. Design scenarios also support Workflow Sensitive sensors. In the Sensors PropertyManager, under Data Quantity, select Workflow Sensitive. Under Properties, select vertices or reference points to graph results.

For legacy studies, selection entities that were listed under Locations for Graphs (Result Options PropertyManager) appear as Workflow Sensitive sensors in the Sensors folder. Legacy Tracked Data Graphs are also mapped to sensors.

See Defining Sensors in the help.

Material
The material libraries for SolidWorks and SolidWorks Simulation have been merged into a single database.

Enhancements to the material user interface:
• Three new tabs, Custom Properties, Application Data and Favorites, have been added in the Material dialog box.
  1. Use the Custom Properties tab to define new properties for custom-defined materials.
  2. Use the Application Data tab to include any descriptive information for custom-defined materials. You can include the content of Application Data in reports. Select Include Application Data under Report Options.
  3. Use the Favorites tab to apply most commonly used materials. Right-click Material in the FeatureManager design tree and select from the list of materials that appear in the menu.

• Source text fields have been added in the Properties, Tables & Curves, and Fatigue SN Curves tabs to include reference information. Type the source of reference for specifying material properties. Reports include the content of the Source field.

• The new Default failure criterion option has been added under Properties. Select an appropriate failure criterion for each material. The user-defined failure criterion is considered by default for the Factor of Safety plot when you select Automatic for Criterion in the Factor of Safety PropertyManager.
(Premium) **Composite Shells**

In earlier releases, only single-layered shells were supported. In this release, you can define a composite shell with up to 50 layers. Each layer can have a different isotropic or orthotropic material.

You can use composite materials for linear static, frequency, and buckling studies. The plies are assumed to be perfectly bonded with no bonding thickness and negligible shear deformation between them.

SolidWorks Simulation supports these composite options:

- **Symmetric laminate**: Define a symmetric stack with respect to materials, ply orientations, and thicknesses about the mid-plane. Material properties can be linear elastic orthotropic, or isotropic.
- **Unsymmetric laminate**: Define an unsymmetric stack with respect to materials (orthotropic or isotropic), ply orientations, or thicknesses about the mid-plane.
- **Sandwich composite**: These are special laminates with three plies arranged in symmetric lay-up about the mid-plane. Material properties can be linear elastic orthotropic, or isotropic. The outer two plies (skins) should be stiffer than the middle ply. The middle ply (core) is usually thicker than the outer plies.

You define ply orientation for composites in the modified **Shell Definition** PropertyManager. You can align plies directly on geometric features without using reference geometry.

After running a static study, you can plot stress values (at top and bottom faces) for each ply or maximum values across all plies. You can also plot stresses in the ply-angle directions.

To plot stresses along the ply-angle direction:

1. In the **Stress Plot** PropertyManager, select **SX:X Normal Stress**.
2. Under **Composite Options**, check **Display results in ply direction on composite surfaces**.
To plot stresses transverse to ply-angle direction, select **SY:Y Normal Stress** in Step 1.

In addition to all stress quantities available for shells, you can also plot interlaminar shear stress. Interlaminar shear stress is reported in local (material) coordinate system for each shell.

**Failure Criteria for Composite Shells**

To determine whether a laminate will fail due to applied loading, the program first calculates stresses in all plies. It applies next a failure criterion based on these stress levels using a failure theory. A laminate is considered to fail when at least one ply fails.

The program applies the Tsai-Wu, Tsai-Hill, and Max stress failure theories to each ply. Tsai-Hill and Tsai-Wu are interactive theories that consider interaction between different components of stress in the failure criterion. The Max stress theory considers a non-interactive stress-based criterion.

See Composite Shells in the help.

**Example of a Composite Shell Study**

You create a buckling study to examine the behavior of a cylindrical composite panel with a circular hole under a compressive load of 100 kN.

To create a composite shell study:

1. Open `Simulation\composite-example.sldprt`

2. To create a new study, click **Study > New Study** on the Simulation CommandManager.

3. Under **Type**, select **Buckling** then click ✓. A Simulation study tab appears below the graphics area and a Simulation study tree appears in the SolidWorks FeatureManager design tree.

4. In the Simulation study tree, right-click the shell icon 🍎 and select **Edit Definition** 🛠️. Under **Type**, select **Composite**. Under **Composite Options**:  
   a) Set **Total Pile**s to **16**.
   b) Select **Symmetric** and **All Pile Same Material**.
   c) Select **Rotate 0° Reference** to rotate the 0 degree ply-angle reference orientation by 90 degrees.
   d) Select **mm** in **Unit** 📊.
   e) Enter the **Thickness** and **Angle** data for the first eight plies:
The remaining eight plies are populated automatically, because the lay-up is symmetric. The program locates the plies from the bottom to the top shell face. The ply lay-up is reversed if you flip the shell faces.

<table>
<thead>
<tr>
<th>Ply</th>
<th>Thickness</th>
<th>Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.142</td>
<td>45</td>
</tr>
<tr>
<td>2</td>
<td>0.142</td>
<td>-45</td>
</tr>
<tr>
<td>3</td>
<td>0.142</td>
<td>90</td>
</tr>
<tr>
<td>4</td>
<td>0.142</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>0.142</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>0.142</td>
<td>90</td>
</tr>
<tr>
<td>7</td>
<td>0.142</td>
<td>-45</td>
</tr>
<tr>
<td>8</td>
<td>0.142</td>
<td>45</td>
</tr>
</tbody>
</table>

f) Under **Composite Orientation**, select **Mirror Orientation**.

5. To apply the same material properties for all plies, click 🎯.

6. In the **Material** dialog box, do the following, then click ✔:
   a) Select **Custom defined**.
   b) For **Model Type**, select **Linear Elastic Orthotropic**.
   c) Set **Units** to **SI**.
   d) Type **Composite1** for **Name**.
e) Type these material properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elastic modulus in x</td>
<td>135e9</td>
</tr>
<tr>
<td>Elastic modulus in y</td>
<td>13e9</td>
</tr>
<tr>
<td>Poisson's ratio in xy</td>
<td>0.38</td>
</tr>
<tr>
<td>Shear modulus in xy</td>
<td>6.4e9</td>
</tr>
<tr>
<td>Shear modulus in yz</td>
<td>4.3e9</td>
</tr>
<tr>
<td>Shear modulus in xz</td>
<td>6.4e9</td>
</tr>
<tr>
<td>Mass density</td>
<td>1.5e3</td>
</tr>
</tbody>
</table>

The program highlights the reference orientation for 0 degree ply angle on the geometry by means of stripes. The material fiber direction for each ply, which is the X direction for material properties is highlighted on the geometry. The Y direction is transverse to fiber direction (on surface) and the Z direction is normal to the ply surface. The images show the X, Y and Z directions for fiber direction angles 0 degrees and 60 degrees.

Fiber direction angle: 0 degrees
Fiber direction angle: 60 degrees

7. Drag the Fixtures and External Loads folders from the Ready study tree to Study 1 tab.
The software copies restraints and loads from Ready study to Study 1.

8. Mesh the panel with the Curvature-based mesher.
   a) Set maximum element size to 5 mm.
   b) Check Draft Quality Mesh under Advanced.
   c) Run the study.

9. Right-click Results and select Define Mode Shape/Displacement Plot. Plot the first two buckling mode shapes.
10. Right-click **Results** and select **List Buckling Load Factors**.

The first five buckling loads agree with numerical results.

<table>
<thead>
<tr>
<th>Buckling Loads (kN)</th>
<th>Mode 1</th>
<th>Mode 2</th>
<th>Mode 3</th>
<th>Mode 4</th>
<th>Mode 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference</td>
<td>107</td>
<td>109.6</td>
<td>116.2</td>
<td>140.1</td>
<td>151.3</td>
</tr>
<tr>
<td>SolidWorks Simulation Professional</td>
<td>107.6</td>
<td>110.7</td>
<td>114.5</td>
<td>140.1</td>
<td>166.7</td>
</tr>
</tbody>
</table>

Multiply buckling load factors by 100 to get the actual buckling loads.

Reference:


**Beams**

The algorithm used to evaluate joints connecting structural members is improved. In earlier releases, some joints for models with crossed beams or complex geometries were incorrectly defined. In this release, the software automatically identifies joints for:

- Touching or interfering structural members.
- Non-touching structural members within a certain distance (tolerance). The software computes an optimal tolerance value, but the user can overwrite it. In the **Edit Joints** PropertyManager, under **Criteria**, check the option **Treat as joint for clearance less than** and set the threshold distance between structural members.

The **Pinball Options** in the **Edit Joints** PropertyManager is removed. The new option **Treat as joint for clearance less than** replaces the definition of pinball radius.

(Premium) Nonlinear static studies now support linear elastic beam elements. All types of loading and restraints for beams that can be defined in static studies are supported for nonlinear studies. You can create shear and moment diagrams and list beam forces and stresses. Large displacement formulation is supported.
No penetration contact is not supported when beam elements are part of the mesh, unless they are treated as solids. To treat a beam as a solid, right-click the beam icon in the study tree and select **Treat as Solid**.

**Thermal Studies**

- You can now select all of the exposed faces of a part or assembly to apply thermal loads. This option is available in the **Temperature**, **Convection**, **Radiation**, **Heat Flux**, and **Heat Power** PropertyManagers. Click **Select all exposed faces** in a thermal load PropertyManager. In assembly documents, you can apply thermal loads to faces of all components. Fully contacting faces of parts are not selected for thermal loads. However, exposed portions of partially contacting faces are selected.

![Model with fully touching faces](image1.png) | ![Model with partially touching faces](image2.png)
---|---
Model with fully touching faces (total of 10 exposed faces) | Model with partially touching faces (total of 12 exposed faces)

- Interaction of thermal studies with static, nonlinear, or transient thermal studies now accommodates dissimilar meshes. After obtaining the temperature distribution from a thermal analysis with certain mesh properties, you can import the temperature data to a static, nonlinear, or transient thermal study with different mesh properties.

![Coarse mesh for thermal study](image3.png) | ![Finer mesh for static study](image4.png)
---|---
Coarse mesh for thermal study | Finer mesh for static study

**Geometry from Deformed Shape**

After running a static or nonlinear study, you can now save the deformed geometry as a new part document, or as a new configuration and create new studies based on it. Studies with solids and surfaces are supported.

You can use this functionality to control the shape of the deformed model for manufacturing purposes. For example, consider a planar plate subjected to a uniform pressure $p$. If you save and manufacture the deformed shape of the plate under a uniform pressure $-p$, the plate will remain planar when the pressure $p$ is applied.
The creation of new studies from deformed geometries of models with beams or sheet metals is not supported in this release. Deformed shapes of assembly documents are saved as multibody parts.

To save the deformed geometry of a part or assembly to a new document:

1. Open Simulation\Tutor1.sdprt
2. Run the Ready study.
3. Right-click Results and select Create Body from Deformed Shape.
4. In the PropertyManager:
   a) Under Save Body as, click Save As New Part/Assembly.
   b) Type Deformed in Part name.
   c) Click .
      A new document Deformed.sldprt is created in the <Examples_dir> directory.

If you run a nonlinear study, the software saves the deformed geometry corresponding to the last solution step.

**Stress/Deformation**

A Stress/Deformation tool is included on the Sheet Metal, Evaluate, and Weldments toolbars to guide you through the common tasks needed to perform an analysis and view the results.

The Stress/Deformation tool works with SolidWorks Simulation Quick Tips to assist you through the analysis workflow. Selecting Stress/Deformation from the Sheet Metal or Weldments toolbars creates a new Static study with gravity applied in the negative Y direction and displays SolidWorks Simulation Quick Tips.

(Premium) **Remote Load/Mass for Linear Dynamic Studies**

You can apply remote loads, or treat a solid body as a remote mass for linear dynamic studies.

You can apply remote loads that are time-dependent for time history studies, or frequency-dependent for harmonic and random vibration studies. To apply a remote load, click External Loads, Remote Load/Mass.

In assembly or multi-body part documents, you now have the option to treat one or more solid bodies as remote masses for linear dynamic studies. Bodies treated as remote masses are excluded from meshing, but their mass properties and moments of inertia are considered in frequency and dynamic analyses. The application of remote mass reduces the mesh size and expedites the solution process, particularly for large assemblies that are subjected to dynamic loading environments.

To treat a solid body as a remote mass, right-click it in the Simulation study tree and select Treat as a Remote Mass. The body appears in the Remote Mass folder. You can select only one body at a time for remote mass.

You can also define a remote mass in with the Remote Load/Mass PropertyManager.
Bodies treated as remote masses are not meshed. All bodies are meshed.

See Treat as Remote Mass in the help.

Assemblies

Enhancements to Assembly Modeling

When working with assemblies, you can exclude selected solid bodies from simulation or treat them as rigid, flexible, floating, or fixed in space. Right-click the part in the study tree to set these options:

- **Exclude from Analysis.** The part is excluded from the study without suppression. This option toggles to Include in Analysis.
- **Make Rigid.** The body is not allowed to deform. Results for its strains and stresses are not computed. However, its contact interactions are considered in simulation. This option toggles to Make Deformable. (Available for static and frequency studies).
- **Make Deformable.** The body is allowed to deform to the extent allowed by its restraints and connections to other parts. Results for its strains and stresses are available.
- **Fix.** The body is not allowed to move. Since the entire body cannot move, it is effectively made rigid as well. A fixed body can still transfer contact interactions to touching parts. This option toggles to Float. (Available for static and frequency studies).

💡 To fix a portion of a body, use the Fixed restraint.

- **Float.** The body can move to the extent allowed by its restraints and connections to other parts. A floating body may be either rigid or flexible depending on the Make Rigid/Make Deformable setting.

⚠️ You should treat a component as rigid only if it is much stiffer than its surrounding components of interest.

For example, the figure below shows stress results for a symmetrical, no penetration contact between a rigid sphere and a flexible block. Note that no stresses develop in the sphere.
Sheet Metal Parts

You can now analyze assemblies made of sheet metal parts, solids, and surfaces. Sheet metal bodies mesh with shell elements. The mesh is located at the mid-surface of the sheet metal.

You can apply all Simulation features directly to the solid geometry. The solver transfers loads, restraints, contact definitions, and connectors to the mid-surface.

Study Tree Enhancements

When you add, delete, or suppress components or bodies in an assembly document in the SolidWorks FeatureManager design tree, the existing Simulation studies are updated automatically. Warning icons next to the **Mesh** and **Results** folders in the Simulation study tree alert you to changes in model geometry.

Connectors

Factor of Safety for Connectors

The Factor of Safety Check is extended to bolt and pin connectors.

After running a static or nonlinear study, you can identify safe and failed connectors. To perform a Factor of Safety (FOS) check for bolt and pin connectors, in the **Connectors**
PropertyManager, expand **Strength Data** and enter the tensile stress area, connector strength, and minimum safety factor. When the analysis is complete, you can view go/no go status for all connectors, as well as their factors of safety. In the graphics area, connectors that are safe are show in green and connectors that have failed are show in red.

For nonlinear studies, the program performs FOS check for each solution step.

See **Factor of Safety for Connectors** in the help.

To perform a FOS check for bolt connectors:

1. Open `Simulation\Basketball_Hoop.sldasm`.
2. Right-click the **Ready** study tab and select **Duplicate**.
3. In the dialog box, type **FOS_check** for **Study Name**. Click **OK**.
   A new **FOS_check** study tab appears at the lower portion of the graphics area.
4. Right-click **BoltConnector-1** in the **FOS_check** study tree and select **Edit Definition**.
5. In the PropertyManager, check **Strength Data** and set the following:
   - Select **Known Tensile Stress Area**.
   - Type **40 (mm²)** for **Tensile Stress Area**.
   - Set **Unit** to **psi** for **Bolt Strength**, and type **3.e07**.
6. Click ✓.
7. Repeat steps 4, 5, and 6 for the other three bolt connectors.
8. Run the study. In the message window, click **No** to solve without using the large displacement option.
9. Right-click **Results** and select **Define Pin/Bolt Check Plot**.
10. Click ✓.
    All four connectors are safe and are listed under the **OK** folder. The bolt connectors are colored green in the graphics area.
    Connectors that fail the FOS check are listed in the **Needs attention** folder. Failed connectors are colored red in the graphics area.
11. Expand the **OK** folder and click **Bolt Connector-2**.
    A callout in the graphics area lists the factor of safety for the connector.
Bolt Connectors
Bolt connectors have been enhanced.

- Bolt connectors for shells are now available. You can define bolts through a mixed stack of solids, shells, and sheet metal bodies.

- **(Premium)** Multi-layered bolts are now available for nonlinear studies. To bolt more than two solid components, in the Connectors PropertyManager, select **Bolt series** under **Advanced Option**, then select the cylindrical faces from the middle components. For nonlinear studies, you can define multi-layered bolts through solid bodies only.

- **(Premium)** Bolts for 1/2 or 1/4 symmetry are now available for nonlinear studies. To define a symmetric bolt, in the Connectors PropertyManager, select **Symmetrical bolt** under **Advanced Option**.
Example of selection entities for a multi-layered symmetric bolt

**Pin Connectors**

Pin connectors are now available for shells.

You can define pin connectors to fasten shell components to solid components or other shells for static, frequency, and buckling studies. For sheet metal parts, you can apply a pin connector to solid cylindrical faces.

**Bearing Connectors**

Bearing connectors are redesigned.

There is no distinction between **Roller** and **Ball** bearing connectors. All bearing connectors now require only cylindrical faces as selection entities.

Self-aligning bearing connectors allow an unrestricted off-axis shaft rotation. You can define axial and radial direction stiffnesses for a self-aligning bearing connector. To define a self-aligning bearing connector, in the **Connectors** PropertyManager, under **Type**, click **Allow self-alignment**. (Available for static, frequency, and buckling studies).

The images show two deformed shapes of a shaft with a bearing connector. A vertical remote load is applied at one side. A bearing connector is applied on a split cylindrical
face of the shaft. When the **Allow self-alignment** option is selected, the cylindrical face of the bearing connector rotates off its axis. When the option is cleared, the cylindrical face is restricted from off-axis rotation.

To prevent rotational instability that can cause numerical singularities, check **Stabilize shaft rotation** in the **Connectors** PropertyManager.

**Mesh**

**Mesh Selection**

You no longer need to select a mesh type when creating a new study. The software automatically assigns the appropriate mesh type to bodies based on their geometry features:

- Solid bodies mesh with solid elements. You can still mesh a solid body as a shell by defining reference surfaces first.
- Surface bodies mesh with shell elements. The software assigns a default shell thickness and thin shell formulation to each surface body. You can edit the default shell definition before running the study.
- Sheet metal bodies with uniform thicknesses mesh with shells created at mid-surfaces. The software assigns a single shell to each sheet metal body. Sheet metal bodies with non-uniform thicknesses mesh with solid elements.

  For drop test studies only, sheet metals parts mesh with solids.

- Structural members mesh with beam elements and the program automatically detects the beam joint group.

The icons in the study tree indicate the mesh type:
After you create a study, you can change the default mesh types for selected bodies:

- To treat a solid body as a beam, right-click it in the study tree and select **Treat as Beam**. Its icon changes to 📜. To convert it back to a solid, right-click and select **Treat as Solid**.

- To treat a sheet metal body as a solid, right-click it in the study tree and select **Treat as Solid**. Its icon changes to 📜. To convert it back to a sheet metal body, right-click and select **Treat as Sheet Metal**.

💡 To mesh a thin solid body with shells, create a mid-surface.

### Curvature-based Mesher

The curvature-based mesher now allows meshing of surfaces in addition to solid bodies. The curvature-based mesher generates a finer mesh on areas of high curvature and transitions the mesh automatically. It supports studies with solid, shell, and beam elements that use incompatible mesh for contact conditions.

To mesh with the curvature-based mesher, in the **Mesh PropertyManager** under **Mesh Parameters**, select **Curvature based mesh**.

Example of a 3D surface model with varying curvature meshed with the curvature-based mesher. The mesher generates finer mesh at regions where the change in curvature is prominent.

![Isometric view](image1.png)  ![Top view](image2.png)

💡 For shell components with touching edges, mesh is always compatible when you select the curvature-based mesher.
**Mesh Control**  
The user interface for component mesh control has been enhanced.

The software automatically refines the mesh based on the volume of the individual components. Previously, if you wanted to specify different element sizes for different components in an assembly, you assigned **Component significance** values in the **Mesh Control** PropertyManager.

To apply mesh control to multiple bodies simultaneously, select **Use per part size** in the **Mesh Control** PropertyManager. The program assigns an element size for mesh control to each component based on each component’s volume. You can still control the element size for mesh control by moving the slider under **Mesh Density**.

![Tip] You can now apply mesh control on components and edges in addition to faces when you choose the curvature-based mesher.

**Simplify Model for Meshing**  
A **Simplify Model for Meshing** option provides quick access to the SolidWorks Utilities **Simplify** tool.

To select the **Simplify Model for Meshing** option, right-click **Mesh** in the Simulation study tree. You can also click **Utilities > Simplify**.

![Tip] Simplification of geometry can alter stress results significantly.

**Contact and Bonding**

**Contact for Nonlinear Studies**  
The solution time for nonlinear problems involving studies of large assemblies with No penetration contact has been improved.

A new **Surface to surface** contact option is available in the **Contact Set** PropertyManager. The application of a finer mesh in the contact area improves the results. You can still use the other contact options, **Node to node** and **Node to surface**, under **Advanced** options in the **Contact Set** PropertyManager.

![Tip] The same approach is used for draft-quality mesh, but using high-quality mesh makes the increased speed for simulation more evident.

**No Penetration and Shrink Fit Contact**  
The interface is simplified by removing options for contact type.

The contact set interface is simplified for the **No penetration** and **Shrink fit** options in the **Contact Set** PropertyManager (static study). The program assigns by default a **Node to surface** contact type to all contact set definitions without user input.

You can assign a **Surface to surface** contact type to all contact definitions by checking **Improve accuracy for contacting surfaces with incompatible mesh (slower)** in the **Static** dialog box.

![Tip] For legacy studies, you can still access the **Node to node**, **Node to surface**, and **Surface to Surface** contact types. On the **Default Options > Mesh**, check **Show
**Advanced Options for Contact Set Definitions (No penetration and shrink fit only)**. The **No Penetration** contact type options become available under **Advanced** in the **Contact Set** PropertyManager.

The source and target grouping for entities is eliminated. You identify faces, edges, or vertices into **Set 1**, and faces into **Set 2** in the **Contact Set** PropertyManager. The solver identifies source and target entities automatically.

**Shell Thickness Consideration**

You can now consider the thicknesses of surface and sheet metal components that mesh with shells for no penetration and virtual wall contact. In earlier releases, shell thicknesses were not considered for contact and bonding. In this release, contact is realized when the distance between the midsurfaces of two shells becomes \((t1+t2)/2\) as shown in the figure. Contact forces are then applied regardless of any clearance shown in result plots. Shell thickness consideration is available for static and nonlinear studies.

![Diagram of shell thickness consideration](image)

- The thicknesses of surface and sheet metal components that mesh with shells for no penetration and virtual wall contact is always considered when you create new static and nonlinear studies. To improve the results of legacy studies, rerun the studies.
- No initial interference should exist between the shell bodies.
- For models that have both solid and surface/sheet metal components, the global option **Ignore clearance for surface contact** in the **Static** dialog box is not supported for no penetration and virtual wall contact. However, you can still set a local condition for ignoring clearances between solid components in the **Contact Set** PropertyManager.

**Bonding**

Enhanced algorithms automatically bond touching entities for the following cases:

- A face or edge of a shell with a solid
- A face or edge of a shell with another shell
- A face of a shell with a structural member

Make sure that the global contact condition is set to **Bonded**.

For touching faces of sheet metal components that mesh with shells created at mid-surfaces, the program transfers the bonding contact to mid-surface shells automatically.
Bonding between touching structural members with a sheet metal face is also automatically created and transferred to mid-surface shells.

For a **Bonded** Contact Set between shell components that is defined with an edge (Set 1) to edge (Set 2) selection set, meshing for the coincident shell edges is compatible when you use the Curvature-base mesher.

**Result Viewing**

**Factor of Safety Check**
Factor of Safety plots have been expanded to studies with shell and mixed mesh.
Factor of Safety plots can now assess the safety of design for shell (single-layered and composite), beam, and mixed mesh models based on a failure criterion assigned for each material. The **Factor of Safety** PropertyManager has been enhanced with new options:

- An **Automatic** option allows you to select the most appropriate failure criteria across all element types. When you select **Automatic** in **Criterion**, the software applies the following conditions:
  
  1. The **Default failure criterion** assigned in the **Material** dialog box for each material. 
     
     📩 See [Default failure criterion](#) on page 113.
  2. If you have not assigned a default failure criterion in the **Material** dialog box, the software assigns the Mohr-Coulomb stress criterion.
  3. If you selected Max von Mises or Max shear (Tresca) criterion for a beam material, the software uses the yield strength as the allowable stress.
  4. If you selected Max normal or Mohr-Coulomb criterion for a beam material, the software uses the tensile strength as the allowable stress.

- A new radio button **Show combined stress on Beams** is added in the **Factor of Safety** PropertyManager to calculate the factor of safety for beams with the worst case combined stress.

- New options for shells allow you to perform design check with the minimum, maximum, top face, or bottom face stresses. The **Membrane** and **Bending** options are removed.

- The Tsai-Wu, Tsai-Hill, and Max stress failure criteria allow you to perform factor of safety check for composite shells.

  📇 In general, for multi-directional laminates, you can test all three criteria to determine the worst case for increasing safety of design.

**Results**

- The deformation plot is merged with the **Plot Results** menu and the **Default Options** dialog box for plots. You can still access deformation plots through the **Displacement Plot** PropertyManager. Clear **Show colors** under **Deformed Shape**.

  📇 Legacy deformation plots are shown as displacement plots with the **Show colors** option cleared.

- A new button **Deformed Result** (Simulation toolbar) toggles the deformed and undeformed shape of the model in an active plot.

  🚨 (Premium) Strain energy density plots are now supported for harmonic and random vibration dynamic studies. To create a strain energy density plot, right-click the **Results** folder and select **Define Strain Energy Density Plot**.

- Selection of nodes and vertices locations for time history and response graphs are now part of the sensor definition. Define **Workflow Sensitive** sensors for locations where you want to graph results from nonlinear, dynamic, and drop test studies and design scenarios.

- You can superimpose a **Design Insight** plot on your model while you are editing geometry features.
**Compare Results**

A Compare Results tool is available for all study types and lets you easily compare studies.

*Compare Results* is available whenever multiple studies or results are available. You can create:

- Comparisons of the current plot to the same study plot from up to three other studies
- Comparisons of arbitrary plots from different studies
- A quick view of the available plots for the current study at the same time
This chapter includes the following topics:

- Installation
- Application Programming Interface
- DWGeditor
- PhotoView 360
- SolidWorks eDrawings
- SolidWorks Rx

**Installation**

**Administrative Image Configuration and Deployment**
SolidWorks Administrative Image configuration and deployment capabilities have been enhanced.

**Option Editor Enhancements**
The SolidWorks Administrative Image Option Editor now supports most SolidWorks installation parameters.

- Specify company contact and product usage information
- Start installations automatically
- Create a diagnostic log for each installation
- Use a different user account when installing
- Update an existing installation location or create a new location
- Specify the locations of standard libraries shared by users and groups
- Use pre-defined options from a previous release or a Copy Settings wizard export file

You now can customize administrative image settings for each machine, rather than for each user. A single administrative image now can serve all users.

**Upgrading an Existing Administrative Image**
Upgrading an existing administrative image has been simplified, both in the Installation Manager and in the documented instructions.

**Restoring Settings from a Previous Image**
When creating or updating an administrative image, you now can re-use installation settings from an existing image.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can re-use users.xml settings from only SW 2009 images. You cannot re-use settings from images created using versions prior to SW 2009.</td>
</tr>
</tbody>
</table>
Installation Manager Support for Manually Downloading Files

It is now possible to use the Installation Manager even when files must be downloaded manually.

The Installation Manager is capable of downloading all files needed to complete an installation. However, in some cases proxy servers installed on the local network or by an internet service provider might prevent an application (such as Installation Manager) from downloading files, while permitting users to download files manually using an internet browser.

Installation Manager enhancements to support manually downloaded files include:

• **One set of files:** The Installation Manager and the Customer Portal now use the same set of downloaded files for installation. You can download manually all files the Installation Manager requires to complete an installation.

• **Automatic processing of manual downloads:** The Installation Manager now detects and processes all files downloaded manually, even if you downloaded files to a different folder or if you missed any files. You can browse to any folder to locate previously downloaded files and then download any remaining files (manually or automatically).

• **Downloading manually within the Installation Manager:** The Installation Manager now specifies exactly what files are required based on what products you are installing and the system requirements. Select the **Individual Files** option on the **Ready to Download** page and follow the instructions. A Web page listing all required files appears in the default Web browser. Click the links to download the files and then follow the instructions to place each file on the computer.

Installation Error Message Links

Under some error conditions, the SolidWorks Installation Manager provides links to Web-based installation information.

This new Web-based capability provides immediate access to the latest installation information, supplementing the information provided in the installation documentation.

Application Programming Interface

Click **Help > API Help** to access the SolidWorks Application Programming Interface (API) Help systems.

The major enhancements made to the SolidWorks API in SolidWorks 2009 are:

• VSTA (Microsoft Visual Basic .NET and C#) macro recording added. Microsoft Visual Studio 2005-formatted, Microsoft .NET version of API Help introduced to support these new macro recording languages.

• Access to coordinate features added (ICoordinateSystemFeatureData interface and IFeatureManager::InsertCoordinateSystem method).

• Access to Save Bodies features added (ISaveBodyFeatureData interface and IFeatureManager::CreateSaveBodyFeature method).

• Support for creating and attaching callouts to a location in space, hiding and showing callouts, and getting and setting the callout's leader properties added (IModelDocExtension::CreateCallout, ICallout::Display, ICallout::GetLeader, and ICallout::SetLeader methods).

• Support for getting sketch's regions and contours added (ISketch::GetSketchRegionCount, ISketch::GetSketchRegions, ISketch::IGetSketchRegions, ISketch::GetSketchContourCount, ISketch::GetSketchContourCount,
ISketch::GetSketchContours, ISketch::IGetSketchContours, ISketchContour::IsClosed, and ISketchRegion::GetFirstLoop methods).

- Support for reordering and reorganizing components added (IAssemblyDoc::ReorganizeComponents and IAssemblyDoc::IReorganizeComponents methods, and DAssemblyDocEvents ComponentReorganizeNotifyEventHandler delegate).
- Support for getting and setting display dimensions’ extension line gaps and jogs added (IDisplayDimension::GetJogParameters, IDisplayDimension::GetWitnessLineGap, IDisplayDimension::SetJogParameters, and IDisplayDimension::SetWitnessLineGap methods).
- Support for selecting hidden bodies added (IBody2::DisableDisplay property).
- Support for editing selected reference points added (IFeatureManager::EditReferencePoint method).
- Notifications added to track changes specific to configurations (DAssemblyDocEvents_ConfigurationChangeEventNotifyEventHandler and DPartDocEvents_ConfigurationChangeEventNotifyEventHandler delegates).
- Notification added to fire when SolidWorks creates a new file (DSldWorksEvents_FileNewPreNotifyEventHandler delegate and swAppFileNewPreNotify enumerator). Support to name the newly created file added (ISldWorks::SetNewFilename method).
- Additional support for Motion Studies added (ISimulation3DContactFeatureData and ISimulationDamperFeatureData interfaces).
- Support for strongly named macro features added.

See the SolidWorks API Release Notes topic, which is available in the API Help, for a list of all of the changes made to the SolidWorks API 2009.

**DWGeditor**

In the DWGeditor®, you can use the SolidWorks 2D View Palette to create drawings from SolidWorks parts and assemblies. After you import a SolidWorks model, you can work with configurations, display modes, and layers. A drawing entity can be parametrically linked to the original SolidWorks model, allowing you to update the drawing when the model changes.

In DWGeditor:
<table>
<thead>
<tr>
<th>Action</th>
<th>Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prepare to work with a SolidWorks model</td>
<td>Click <strong>Tools &gt; View Palette</strong>.</td>
</tr>
</tbody>
</table>
| Open a SolidWorks model | Do one:  
  - Click **Browse for SolidWorks model** and select a model file.  
  - Drag a model file from Microsoft Windows® Explorer to DWGeditor.  
  - Open a model in SolidWorks, then start DWGeditor.  
  Available views of the model appear on the View Palette. |
| Add a view to a drawing with a parametric link to SolidWorks | Clear **Insert as Block Reference**, then drag the view to the drawing sheet.  
A SolidWorks drawing view entity is added to the sheet.  
You cannot edit this entity. |
| Add a view to a drawing without a parametric link to SolidWorks | Select **Insert as Block Reference**, then drag the view to the drawing sheet.  
A block is added. You can explode the block to create individual sketch entities. |
| Convert a SolidWorks entity to a block | Select the object on the drawing sheet and explode it by clicking **Modify > Explode**.  
The parametric link to SolidWorks is removed. |
| Update a drawing when a model changes | Click **Tools > Update Views**.  
The SolidWorks drawing view entities are updated. |

Before adding a view to a drawing, on the View Palette:

<table>
<thead>
<tr>
<th>Action</th>
<th>Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work with a different configuration of the model</td>
<td>For a SolidWorks model with more than one configuration, select a new value from <strong>Configuration</strong>.</td>
</tr>
<tr>
<td>Set the size of an object in the drawing</td>
<td>Type a value for <strong>Drawing View Scale</strong> or select <strong>Specify On-screen</strong>.</td>
</tr>
<tr>
<td>Select the display mode for an object</td>
<td>From <strong>Display Style</strong>, select <strong>Hidden Lines Removed</strong>, <strong>Hidden Lines Visible</strong>, or <strong>Wireframe</strong>.</td>
</tr>
<tr>
<td>Define visual properties for visible edges, hidden edges, and tangent edges</td>
<td>Define layers. Then select distinct layers for <strong>Visible Lines Layer</strong>, <strong>Hidden Lines Layer</strong>, and <strong>Tangent Lines Layer</strong>.</td>
</tr>
</tbody>
</table>

**PhotoView 360**

PhotoView 360 is a state-of-the-art progressive rendering solution for SolidWorks models. This new product is included for users of SolidWorks Office, SolidWorks Professional, and SolidWorks Premium.
You must have a valid SolidWorks license installed on your system to use PhotoView 360. If you have a valid license but get a license error message, reactivate PhotoView 360 by selecting **Activate Licenses** from the **Help** menu.

### SolidWorks eDrawings

**Graphics Hardware Acceleration Options**
You can select graphics card hardware acceleration options from the **General** tab of the **Options** dialog box. SolidWorks eDrawings® initially sets these options based on your graphics hardware.

Select **Graphics boost** to use your graphics card hardware acceleration. Select options to optimize for speed or appearance.

💡 If you experience display problems with eDrawings and your graphics card is not on the list of approved graphics cards, close all open files and clear **Graphics boost**.

Clearing **Graphics boost** is equivalent to selecting **Use software OpenGL** in previous releases.

**Appearances and Scenes**
eDrawings now supports the appearances, scenes, and lighting defined in SolidWorks 2009 parts and assemblies. eDrawings also now applies floor reflection to parts and assemblies from all supported applications.

💡 You must select **Best appearance** under **Graphics boost** to view these display settings in eDrawings.

**Assembly Bills of Materials in eDrawings**
eDrawings supports viewing BOM data stored within SolidWorks part or assembly files. You can also save the BOM data to an eDrawings part or assembly file.

When saving the selected SolidWorks document, click **Options** in the **Save As** dialog box, and select **Save Bill of Materials features to eDrawings file**.

✏️ When you open files that include BOMs, you can view a BOM but not move or resize it.

### SolidWorks Rx

**Problem Capture**
You can now provide more information when you report a problem.

To start Problem Capture, start SolidWorks Rx and click the **Problem Capture** tab.

In step a, the **Problem Capture Detail** form prompts you for more detailed information than it did previously.

In step b, when you recreate the problem, you can:

- Use the data from your last SolidWorks session.
• Record a video that recreates the problem in a new SolidWorks session or in the current session.
This chapter includes the following topics:

- FeatureWorks
- PhotoWorks
- Design Checker
- SolidWorks Tools
- SolidWorks Utilities
- Toolbox

### FeatureWorks

#### General

**FeatureWorks Options Dialog Box Enhancements**

- The Options dialog box is reorganized. All existing options are still available. Select from these categories:
  - General
  - Dimensions/Relations
  - Resize Tool
  - Advance Controls

- The Resize Tool Recognition Order dialog box lets you set the recognition order for features you create using the resize tool. Upon feature recognition, FeatureWorks creates resized features in the order you set.

- Click Default to reset all values to the default FeatureWorks values, including the feature selection filters.

**User Interface Enhancements**

- The PropertyManager has been redesigned to improve usability:
  - The single FeatureWorks PropertyManager has been split into three wizard-like PropertyManagers: Feature selection, Intermediate for feature recognition operations, and Pattern Recognition.

- Click graphical navigation tools , , , and  to move through the wizard-like recognition process.

- The navigation tools replace the FeatureWorks FeatureManager dialog box, which has been removed. The dialog box functionality, such as Recognize Patterns, Map Features, and Continue, has been integrated into the PropertyManagers.

- Colored Message boxes in the PropertyManagers guide you through the recognition process.
• In the **FeatureWorks** PropertyManager, the **Automatic Features** section has feature selection filters to select all or clear all features.
• You can undo resize tool actions with a single undo command instead of multiple commands.

**Automatic Dimensions and Relations**
FeatureWorks can automatically add dimensions to features it recognizes. FeatureWorks has increased the kinds of 2D sketch relations it can recognize.
• FeatureWorks supports baseline, chain, and ordinate dimensioning schemes.
• FeatureWorks recognizes concentric relations.

![Example of recognized concentric relations](image)

⚠️ See Recognized Sketch Constraints in the help.

**Adding Dimensions and Relations**
To add dimensions and relations when you recognize features:

1. **Open** **FeatureWorks\AutoDimension.x_t**.
   Click **No** if prompted to run Import Diagnostics. Click **No** if prompted to run feature recognition.

2. **Click** **Options** (FeatureWorks toolbar) or **FeatureWorks > Options**.
3. **Click--** **Dimensions/Relations** and select **Enable Auto Dimensioning of Sketches** and **Add constraints to sketch**.
4. **Click** **OK**.

5. **Click** **Recognize Features** (FeatureWorks toolbar) or **FeatureWorks > Recognize Features**.
6. In the PropertyManager, select **Automatic** recognition, **Standard features**, and all features except **Volume**.
7. **Click** to continue recognizing features.
8. **Click** in the new **Intermediate Stage** PropertyManager to create the features. FeatureWorks analyzes the model and creates a revolve feature.
9. **Edit** the revolve’s sketch to view the dimensions and relations.
Base Loft Recognition
FeatureWorks can interactively recognize base lofts.

FeatureWorks recognizes base lofts with two or more similar or dissimilar profiles. The profiles can be parallel or non-parallel.

Unsupported Loft Entities:
- End conditions Normal to profile and Direction vector
- Guide curves
- Profile connectors
- Splines as profiles

Recognizing Lofts
To interactively recognize base lofts:

1. Open FeatureWorks\BaseLoft.x_t.
   Click No if prompted to run Import Diagnostics.
2. Do one:
   - Click Yes if prompted to run feature recognition.
   - Click Recognize Features (FeatureWorks toolbar) or FeatureWorks > Recognize Features.
3. In the PropertyManager:
   a) Select Interactive under Recognition Mode.
   b) Select Standard features under Feature Type.
4. Under Interactive Features:
   a) Select Base-Loft in Feature type.
   b) Select the faces shown for End Face 1 and End Face 2.
5. Click Recognize.

6. Click ✓.

**End Conditions for Holes and Cut Extrudes**
FeatureWorks has increased the kinds of end conditions it recognizes for holes and cut extrudes.

In addition to **Blind**, FeatureWorks now recognizes these end conditions for holes and cut extrudes:
- **Up to Next**
- **Through All**

Use Automatic or Interactive mode to recognize these end conditions.

For holes, FeatureWorks also recognizes these end conditions when you use the resize tool.

**Mirror Patterns**
FeatureWorks recognizes mirror patterns.

You can recognize mirror patterns using Automatic or Interactive mode. FeatureWorks automatically selects the mirror plane.

**Recognizing Mirror Patterns**
To automatically recognize mirror patterns:

1. **Open** FeatureWorks\MirrorPattern.x_t.
   - Click **No** if prompted to run Import Diagnostics.

2. Do one of the following:
   - Click **Yes** if prompted to run feature recognition.
   - Click **Recognize Features** (FeatureWorks toolbar) or FeatureWorks > Recognize Features.

3. In the PropertyManager, select **Automatic** recognition and click to recognize features using the other default settings.

4. Under **Recognized features**, click **Find patterns**.

5. In the **Pattern Recognition** PropertyManager:
   a) Select **Automatic** in **Pattern Recognition Mode**.
b) Select **Mirror** in **Pattern Type**.

c) In **Pattern Features**, select **Boss-Revolve6** shown for **Seed feature**.

![Image showing Mirror in Pattern Type]


d) Select **Boss-Revolve1** shown for **Mirror feature**.

![Image showing Mirror feature]

e) Click 💄.

A dialog box reports 2 mirrors found. FeatureWorks calculates mirrors for the revolves and holes as separate features.

6. Click **OK** to close the dialog box.

7. Click ✔️.

FeatureWorks calculates the mirror plane and creates mirrors for all features with valid mirrors about that plane.

8. In the FeatureManager design tree, select the mirror features to highlight them in the graphics area.

![Image showing Mirror features highlighted]

### Resize Tool

FeatureWorks® software has increased the number of features you can directly edit using the resize tool.

You can directly edit these features using the resize tool:

- Boss revolve
- Cut revolve
- Edge flange
- Hem flange
PhotoWorks

Preview Window
Display the Preview window to see an accurate, interruptible, view of a rendered model. Complicated models can take a long time to render. Use the Preview window to save time before you commit to a full rendering.

Click PhotoWorks > Preview Window. When the teapot in the upper right corner stops spinning, the window has finished updating. Within the Preview window, you can zoom, pan, or change the view orientation.

💡 Small preview windows are updated more quickly than larger ones.

As you change the model in the graphics area, the Preview window synchronizes with, but does not disrupt, your work. The rendering preview restarts for most changes. When you edit features or components, the Preview window pauses until you complete the change.

Work with the toolbar buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop / Resume</td>
<td>Suspends the preview in its current state. When you resume, the preview undergoes a single translation before refinement restarts.</td>
</tr>
<tr>
<td>Save</td>
<td>Takes a snapshot of the preview as of the moment you click Save in the Save As dialog box.</td>
</tr>
<tr>
<td>Fit to screen</td>
<td>Displays the entire model within the Preview window.</td>
</tr>
<tr>
<td>Zoom to area</td>
<td>Selects a smaller area of the model to view within the Preview window.</td>
</tr>
<tr>
<td>Zoom In/Out</td>
<td>Views the preview in more or less detail.</td>
</tr>
<tr>
<td>Pan</td>
<td>Changes the position of the preview within the window.</td>
</tr>
<tr>
<td>View orientation</td>
<td>Selects a new orientation, which can be different from the one in the graphics area.</td>
</tr>
</tbody>
</table>

Abstract Scenes
Additional abstract scenes, including a new default background, are available. On the Appearances/PhotoWorks tab, select Scenes > Basic Scenes.
In a reflective environment, colors and images in real-world scenes can distract from the model. An abstract scene is an environment more typical of the setup in a photography studio. It does not contain recognizable objects other than lighting. With abstract scenes, the viewer focuses on the model, rather than the background.

The background and reflective environment are the same in these abstract scenes.
<table>
<thead>
<tr>
<th>Scene</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backdrop - Ambient White</td>
<td></td>
</tr>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>Backdrop - Black with Fill Lights</td>
<td></td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
<tr>
<td>Backdrop - Grey with Overhead Light</td>
<td></td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td><img src="image6.png" alt="Image" /></td>
</tr>
<tr>
<td>Backdrop - Studio Room (default scene)</td>
<td></td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td><img src="image8.png" alt="Image" /></td>
</tr>
</tbody>
</table>
Effect Scene  Effect

Backdrop - Studio with Fill Lights.

**Aspect Ratio**
You can now change a camera’s aspect ratio, giving you more control when you define a camera view, render a model, or save an Animator file.

- You can express an aspect ratio:
  - Explicitly, by setting **aspect ratio**, the ratio of width to height. These formats are equivalent:
    
    1.33
    4 : 3
    4 / 3
    4 x 3
  
- Implicitly, by setting the width and height of the image in pixels, inches, or centimeters.

You can fix an aspect ratio and change the width or height only. The other dimension updates proportionately.

💡 Aspect ratio is independent of resolution.

- When you set up a camera, you can specify the aspect ratio. A Field of View rectangle shows the shape and area of the model that is visible to the camera.

Example: Camera setup

Setting the aspect ratio changes how much of the model is visible if you render to a file, as displayed between the horizontal and vertical lines in the Field of View rectangle.
• In the graphics area, when you set the view orientation to a camera, the camera's field of view is visible by default.
Right-click in the graphics area and select **Display Field of View Box** to toggle the Field of View display off and on.

- When you render to a file or save an animation to a file, the aspect ratio affects the view of the model in the resulting file. As you change the aspect ratio, the image in the graphics area provides a preview of the result.

### Design Checker

**User Interface**
The user interface of the Design Checker has changed to be more consistent with the SolidWorks UI.

Highlights:

- In the **Build** tool:
  - Click **Show All Checks** to switch between viewing only the requirements for the active tab and the requirements for the current standards file.
  - Click the title bar or the appropriate window controls to collapse or expand requirements.

- **Design Checker > Check Active Document** displays a **Design Checker** tab in the Task Pane rather than displaying the **Select Standards** dialog box.

- Click **Add Standards** (+) or **Remove Standards** (-) to add or remove files.
- Select or clear the check boxes to specify which standards files to use in the validation.
- After you check a document, click **Results** or **Settings** to switch between windows.

### New Validation Checks
Design Checker provides new types of validation checks.
### Auto Correction?

<table>
<thead>
<tr>
<th>Check</th>
<th>Description</th>
<th>Auto Correction?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dangling Dimension / Annotation on Drawing Document Checks tab</td>
<td>Checks for dimensions or annotations that no longer have a reference.</td>
<td>No</td>
</tr>
<tr>
<td>Extension Line Visible Gap on Drawing Document Checks tab</td>
<td>On drawings, checks the gap between an object and the origin of an extension line of dimension. Also checks for extension lines beyond the dimension line.</td>
<td>Yes</td>
</tr>
<tr>
<td>Interference Volume on Assembly Document Checks tab</td>
<td>Checks for the interference of components in an assembly.</td>
<td>No</td>
</tr>
</tbody>
</table>

### Custom Checks

You can create macros that perform custom checks.

Use the **Document Checks** tab to add and view macros.

To create validation macros, click **Tools > Macro > New**. The macro cannot have arguments. Call `SetCustomCheckResult` to indicate what to show on the result page, passing one of the following values:

- `true` - the check passes
- `false` - the check fails

Read about **Custom Check** in the Design Checker API Help for information about Design Checker objects and methods.

Custom check macros are now stored with the standards file to make it easier to distribute the correct combination of standards and macros to multiple users.

- When you save a standards file that includes a custom check, the associated macro is saved with the other standards.
- To save an updated macro, go to the **Document’s Custom Check** window where you added the macro. Reselect the **Macro File Path** and the **ModuleName.Procedure Name**.

### Specifying a File Location

A system option lets you specify the directory for Design Checker files.

To check or set the directory:

1. Click **Options**.
2. Select **File Locations**.
3. From **Show folders for**, select **Design Checker Files**.
4. Add or change one or more directories.
   - Design Checker uses the standards files, `.swstd`, in the specified directories, but not in subdirectories.

### Validating Documents Sequentially

You can validate multiple documents sequentially without having to restart Design Checker for each document.
To validate more than one open document:

1. Check the first active document and review the results.
2. Switch to the second document. The Design Checker tab on the Task Pane remains open.
3. Click Check Document to validate the second document using the same settings. You can now view both results sets by switching between active documents.

**New Result Category: Not Applicable Checks**

Design Checker validation can produce results in a new category, Not Applicable Checks. For example, when you validate an assembly, the results for any tests that check drawings are categorized under Not Applicable Checks.

**SolidWorks Tools**

**Task Scheduler**

**Design Checker**
You can select multiple standard files when you run the Design Checker task in SolidWorks Task Scheduler. In earlier releases, you could only select a single standard file.

**File Conversion**
The new Convert Files task in the SolidWorks Task Scheduler replaces the Conversion Wizard as the utility for performing file conversions from earlier SolidWorks releases.

For more information, see Converting Files to the Current Version of SolidWorks on page 14.

**Property Tab Builder**
A new interface is available for entering custom and configuration-specific properties into SolidWorks files.

You customize the Custom Properties tab using the new Property Tab Builder, which is a stand-alone utility. You can create different versions of the tab for parts, assemblies, and drawings.

See Custom Properties on page 15.

**SolidWorks Utilities**

**General**
The SolidWorks Utilities user interface has been modified.

**Tools Moved to Task Pane**
Most tools now open in the Task Pane instead of in dialog boxes. Their functionality is unchanged.

Affected tools:

- Compare Documents
• Compare Features
• Compare Geometry
• Find Features
• Modify Features
• Suppress Features
• Simplify
• Feature Paint
• Power Select

Compare Documents

You can run Compare Documents on parts in the SolidWorks Enterprise PDM software. See Compare Documents in the Enterprise PDM What's New.

Format Painter

The Format Painter tool has been removed from Utilities and added to the Tools toolbar in the SolidWorks software.

For more information, see Format Painter on page 97 and Using Format Painter on page 97.

Coordinate Systems Alignment

You can align parts using coordinate systems before comparing their geometry.

Select Align parts using Coordinate system in the Compare Geometry pane.

This option is useful for comparing geometrically similar bodies located in different positions, relative to the origin.

Aligning Coordinate Systems

To align coordinate systems:

1. Open Utilities\Short.sldprt and Long.sldprt.
   The parts have different positions related to the origin. They have a coordinate system, CS1, which you can use to align them.
2. In Long.sldprt, click **Compare Geometry** (Utilities toolbar) or **Utilities > Compare Geometry**.

3. In the **Compare Geometry** Task Pane:
   a) Select Long.sldprt in **Reference Document**.
   b) Select Short.sldprt in **Modified Document**.
   c) Select **Align parts using Coordinate system**.
   d) Under **Alignment**, select **CS1** for the reference and modified document’s coordinate system.
   e) Click **Compare**.

The volume comparison window shows a useful comparison because of the aligned coordinate systems.

   ![Results with alignment option selected](image)
   ![Results with alignment option cleared](image)

4. Click **Close** in the Task Pane and do not save the comparison results.

**Symmetry Check**

**Symmetry Check** is modified and enhanced.

PropertyManager Enhancements:

- The **Message** section displays messages to guide you.
- The **Type of Check** section displays two options:
  - **Manual Face Check**. Checks for symmetry using the existing functionality.
  - **Automatic Symmetry Split**. New functionality that automatically reduces a part to its smallest repeatable symmetrical body. This functionality is especially useful when you run analyses using the SolidWorks Simulation software.
Using Symmetry Check
To use Automatic Symmetry Split:

1. Open Utilities\Symmetry.sldprt.

2. Click Symmetry Check (Utilities toolbar) or Utilities > Symmetry Check.

3. Under Type of Check, select Automatic Symmetry Split.
   The Message box prompts you to select a body to keep.

4. Hover over areas of the model to preview the smallest symmetrical bodies to which you can reduce the part.
   Three bodies are available.

5. Select the lower body shown. You can select one body only.
   The body name appears in Body for Split.

6. Click Split Part.
   The model is reduced to the selected body. A Split feature appears in the FeatureManager design tree.

Toolbox

Enabling SolidWorks Toolbox
It is now easier to enable SolidWorks Toolbox.

After you install SolidWorks, clicking Toolbox in the Design Library can display status messages about Toolbox installation and in some cases, suggestions for corrective actions.
Examples:

- If Toolbox components were not installed during the SolidWorks installation, a message reminds you.
- If you have installed Toolbox components on your computer, you should consider whether a centralized Toolbox on another computer is shared within your work group.
- If you have configured access to a centralized Toolbox using a Windows mapped drive, you should consider using a UNC path instead.

**SolidWorks Toolbox Configuration**

The Toolbox configuration interface now guides you through the process of configuring hardware.

The utility has five pages, one for each configuration task:

- Selecting standards and hardware
- Customizing hardware properties
- Setting Toolbox user settings
- Setting permissions for modifying Toolbox data
- Configuring Smart Fasteners

To configure Toolbox:

1. Click **Options** or **Tools > Options**.
2. Click **Hole Wizard/Toolbox** and then click **Configure**.

**Automatic Lengths for Smart Fasteners**

You can configure Smart Fasteners to automatically adjust the fastener length to your thread engagement requirements. You can accept or override the automatic length when you create a hole series or add a fastener.

In the **Toolbox** interface, on the **Smart Fasteners** page, you can adjust the fastener length to be:

- A number of threads beyond the nut
- A multiple of the tapped hole diameter

**Toolbox Materials**

You can specify material properties for standard fasteners. The list of materials is common to SolidWorks and SolidWorks Simulation. You assign materials to a fastener using a custom property on the **Customize Hardware** page in the **Toolbox** interface.

**Localized Fasteners for the GB Standard**

SolidWorks displays GB standard fastener names and designations in the installed language. You can enable localized component names in the FeatureManager and in BOMs by using Toolbox user settings.

To display localized GB standard fasteners:

1. Click **Options** or **Tools > Options**.
2. Click **Hole Wizard/Toolbox** and then click **Configure**.
3. Click **Define user settings**.
4. Under **Designation (For DIN, GB, and ISO only)**, select one or more of these options:
• Show as Component Name in FeatureManager
• Show as Part Number in Bill of Materials
• Show as Description in Bill of Materials

Korean and Indian Standards
SolidWorks Toolbox contains Korean (KS) and Indian (IS) standards for hardware.

Unloading Toolbox Components
You can unload Toolbox components using two new tools, Select Toolbox and Unload Hidden Components. Unloading Toolbox components reduces the amount of memory the software uses and can improve performance in large assemblies.

To unload SolidWorks Toolbox components:

1. Click Select (Standard toolbar) and then Select Toolbox. All Toolbox components in the assembly are selected.
2. In the FeatureManager design tree:
   a) Right-click a selected Toolbox component and select Hide components
   b) Right-click the assembly and select Unload Hidden Components.

The components are unloaded from memory and are not visible in the graphics area, but the effects of their mates are retained.

Graphical Sizing Tools
You can set the size and length of Toolbox components in the graphics area when you add or edit them in assemblies.

Drag to change the length. Select from the list in the callout to change the size.
This chapter includes the following topics:

- CircuitWorks
- ScanTo3D
- Routing
- TolAnalyst

CircuitWorks Models

The CircuitWorks™ add-in, now included in SolidWorks Premium, lets you create 3D models from the IDF and PADS file formats written by most Electrical Computer Aided Design (ECAD) systems. Electrical and mechanical engineers can collaborate to design printed circuit boards that fit and function in SolidWorks assemblies.

Use CircuitWorks to:

- Import ECAD files of printed circuit board data into SolidWorks.
- Filter out board elements such as components or plated holes.
- Save commonly used filter settings for reuse.
- Compare circuit board files.
- Access a library of circuit board components.
- Modify board elements.
- Export circuit board models from SolidWorks.

User Interface

The CircuitWorks FeatureManager tree and preview tools let you locate and modify printed circuit board entities.

The FeatureManager tree shows ECAD data from the imported circuit board. The structure of the tree depends on what features are supported for the file type and on the entities included in the imported circuit board.

Top level directories can include:

- Boards (Board Outlines, Non-plated Holes, and Plated Holes)
- Components
- Keep-In and Keep-Out Areas

You can expand directories, right-click items in the tree to apply filters, zoom or highlight items, and modify properties.

Use tools on the Preview tab to change the view and perspective of the image. Use tools on the Show tab to show or hide entities, such as Outlines or Filtered Items.
Filtering
Apply filters to reduce visual complexity in a circuit board drawing or to eliminate entities not necessary for the SolidWorks model.

You can set up filters for board elements such as Components, Plated Holes, and Outlines.

Use Export Filters and Import Filters to save complex rule sets and reapply them to other files.

Generating a Model
CircuitWorks uses the ECAD data in IDF and PADS files to generate SolidWorks models automatically.

To generate a model from an ECAD file:

1. From the CircuitWorks menu, click Open ECAD File, select CircuitWorks\cellphone.emn, and click Open.

2. Select Tools > SolidWorks > Build Model.

   The file is scanned and any warning messages are displayed before the build begins.

   For this example, you see: This file contains 8 zero height Components which SolidWorks will model as 2D sketches.

3. Read additional information below the item list:
   Zero height components are marked in the list on the left and will not be extruded by CircuitWorks. Click on the component to add a height value if required.

4. Click Cancel.

5. To locate the zero height components:
   a) Select Tools > Filter > Components.
   b) In the Component Filters panel, select Taller than and enter 0.

   The zero height components are displayed in the FeatureManager tree.
c) Select CONN_6212_30_POLE.
All instances of the component (in this example, X200) are highlighted.

6. In the Component Properties dialog, enter 2.0000 for Height (mm).
7. Locate and modify the remaining zero-height components.
8. Click ✅.
9. When you see Process Complete 😊, close the progress dialog box.
10. Exit CircuitWorks to view the completed model.
ScanTo3D

Curve Wizard
The ScanTo3D Curve Wizard can now import and edit IGES, IBL, and TXT files containing point data that defines discrete curve sets. These enhancements are most useful to advanced SolidWorks users in the aerospace and engineering markets, and to those who define curves by mathematical formulas.

The Curve Wizard user interface has been modified to support these files.

Importing Discrete Curve Sets

To import discrete curve sets using the Curve Wizard:

1. Open a new part.
2. Click Curve Wizard (ScanTo3D toolbar) or Tools > ScanTo3D > Curve Wizard.
3. In the PropertyManager, click Browse for Mesh/Cloud/File.
4. Browse to ScanTo3D\ClosedCurve.csv and click Open.

Under Creation Method, Discrete is automatically selected. Under Creation Parameters, two discrete curve sets are listed. You can use the editing tools to edit the curves.

5. Click ✓.

The software imports the curves as a 3D sketch.

Routing

General

Enhancements to the workflow and usability in SolidWorks Routing:

- All route sub-assemblies, as well as route components such as pipes, cables, and tubes, are now created as virtual components. This streamlines the route creation process and simplifies data management.
- The FeatureManager design tree representation for route sub-assemblies has been simplified. A Components folder contains items such as connectors, flanges, and elbows. A Route parts folder contains items such as pipes, tubes, and cables.
- You can undo the drag and drop of a routing component into a route sub-assembly.
- Shortcut menus have been enhanced to present the most commonly used routing commands and group them under a Routing heading.
- In the Auto Route PropertyManager, select Flip through clip, and then click a clip in the graphics area to change the direction of the route through the clip.
The behavior of route sketches has been modified so that you can no longer accidentally reverse the direction in which the route exits a flange or connector. Previously, it was possible to drag a sketch line such that the route exited from the front of the flange or connector instead of from the rear.

The old electrical harnessing and wiring summary functionality and toolbars are no longer available. They have been replaced by the new flattening methods. See Drawings of Electrical Routes on page 162.

Error Messages

Error messages have been enhanced. You can click How do I fix this? for detailed suggestions for fixing the error. If you exit the route sketch without fixing the error, 📢 appears on the route in the FeatureManager design tree, and you can access the error message in the What's Wrong dialog box.

Point-to-Point Routes

- “Routing on the fly” has been renamed to “point-to-point routing”.
- You can select a circular edge to start a point-to-point route.

Toolbars

The following new tools appear on routing toolbars:

Table 1: Electrical

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Start By From/To</strong></td>
<td>Starts an electrical route by importing a from/to list. Replaces Create Route by From/To Import.</td>
</tr>
<tr>
<td></td>
<td><strong>Start By Drag/Drop</strong></td>
<td>Starts an electrical route by drag/drop of a connector. Replaces Create Route by Drag and Drop.</td>
</tr>
<tr>
<td></td>
<td><strong>Start At Point</strong></td>
<td>Starts an electrical route on the fly. Replaces Create Route on the fly.</td>
</tr>
<tr>
<td></td>
<td><strong>Re-Import From/To</strong></td>
<td>Re-imports the from/to list.</td>
</tr>
<tr>
<td></td>
<td><strong>Insert Connectors</strong></td>
<td>Inserts multiple instances of an electrical connector into the assembly.</td>
</tr>
<tr>
<td></td>
<td><strong>Add Point</strong></td>
<td>Ends an electrical route on the fly.</td>
</tr>
</tbody>
</table>
### Table 2: Flexible Tubing

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Start By Drag/Drop" /></td>
<td><strong>Start By Drag/Drop</strong></td>
<td>Starts a tube route by drag/drop of a fitting. Replaces Create Route by Drag and Drop.</td>
</tr>
<tr>
<td><img src="image" alt="Start At Point" /></td>
<td><strong>Start At Point</strong></td>
<td>Starts a tube route on the fly. Replaces Create Route on the fly.</td>
</tr>
<tr>
<td><img src="image" alt="Add Fitting" /></td>
<td><strong>Add Fitting</strong></td>
<td>Adds a fitting to the route.</td>
</tr>
<tr>
<td><img src="image" alt="Add Point" /></td>
<td><strong>Add Point</strong></td>
<td>Ends a tube route on the fly.</td>
</tr>
</tbody>
</table>

### Table 3: Piping

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Start By Drag/Drop" /></td>
<td><strong>Start By Drag/Drop</strong></td>
<td>Starts a pipe route by drag/drop of a fitting. Replaces Create Route by Drag and Drop.</td>
</tr>
<tr>
<td><img src="image" alt="Start At Point" /></td>
<td><strong>Start At Point</strong></td>
<td>Starts a pipe route on the fly. Replaces Create Route on the fly.</td>
</tr>
<tr>
<td><img src="image" alt="Add Fitting" /></td>
<td><strong>Add Fitting</strong></td>
<td>Adds a fitting to the route.</td>
</tr>
<tr>
<td><img src="image" alt="Add Point" /></td>
<td><strong>Add Point</strong></td>
<td>Ends a pipe route on the fly.</td>
</tr>
</tbody>
</table>

### Electrical Routes

#### Drawings of Electrical Routes

You can now create electrical drawings at the same time you flatten the 3D electrical route assembly in the **Flatten Route** PropertyManager. You can include balloons and various electrical tables on the drawing. The tables are automatically placed so that they do not overlap each other or the model geometry.

💡 You can also add tables to drawings by clicking **Insert > Tables > Electrical Tables**.

#### Creating a Drawing

1. Open `Routing\SensorEnclosure\routeAssy2-_Sensor Enclosure.sldasm`

2. Click **Flatten Route** (Electrical toolbar) or **Routing > Electrical > Flatten Route**.

3. In the PropertyManager, under **Flatten Options**, select **Display 3D Connectors**.

4. Select **Create Electrical Drawing** and select:
   - Electrical BOM
   - Cut List
   - Connector Table
   - AutoBalloon

5. Click ✔️.
A flattened configuration is created in the route assembly file, and a drawing file is created. The drawing contains the tables and balloons you selected in the PropertyManager.

Keep the files open for the Highlight Search example below.

**Highlight Search**
You can select text strings in an electrical (ECAD) drawing and search an electrical route assembly for corresponding items.

**Highlight Search** enables you to capture a string of text from items such as imported schematic drawings or natively created electrical drawings. Then in an electrical route assembly, you can search for corresponding 3D electrical items such as core wires, cables, assemblies, end connectors, and other electrical routing components. When **Highlight Search** finds these items, they are highlighted in the graphics area and can be used for additional finer searches.

**Activating Highlight Search**
To activate **Highlight Search**:

1. In the Task Pane, select the **Highlight Search** tab.
2. Click ‭to pin the Task Pane open.

**Finding Components**
To find a component:

1. In the Task Pane, under **Text Capture**, select **Connector**.
2. In the graphics area of the drawing, zoom to the area shown below:

3. In the table, select the cell that contains the text **Part:connector (3pin) female-2**. The text appears in **Search text** in the Task Pane.

   ‭You can also type text in **Search text**.

4. In the Task Pane:
a) Click **Find**.
The assembly becomes the active document, and a connector is highlighted in the FeatureManager design tree and graphics area. In the Task Pane, under **Results**, the full component name appears in **Component name**. Wires related to the connector appear in **Related wires/cables**.

b) Click **Zoom**.
The graphics area zooms to the highlighted connector.

You can also view the connector in the non-flattened view of the route.

5. In the FeatureManager design tree, right-click **Route** and select **Show configuration**.
6. Change the view to **Isometric**.
7. In the Task Pane, click **Find**.
The connector is highlighted again.

8. In the Task Pane:
   a) In **Related wires/cables**, select **20gred_2@routeAssy2_-_Sensor Enclosure**.
   b) Click **Find**.
The wire is highlighted in the graphics area.

**ECAD Interfaces**

You can import an AutoCad® Electrical, EPlan, or Mentor drawing and use the net list from that drawing to drive the creation of an electrical route in SolidWorks. You can import the data by clicking **Start By From/To** (Electrical toolbar) or by dragging the net list into an assembly.

**Electrical Bills of Materials**

Enhancements:
• The **Electrical BOM** and **Cut List** tables are now native SolidWorks tables. You can edit the tables to add and delete columns, and save the tables as templates.

• In the BOM, you can now access properties you add in custom columns in the cable/wire library. To add a custom column to the cable/wire library, right-click an existing column header, select **Insert**, and then **Column Right** or **Column Left**.

**TolAnalyst**

**Constructed Features**

When you perform a tolerance study using TolAnalyst™, it now considers dimensions and tolerances you apply to constructed features with DimXpert for parts, and their effect on other features in the tolerance chain.

Affected Constructed Features:

• Intersect points
• Intersect lines
Intersect Lines Example

Using TolAnalyst, you create a study to determine the tolerance stack for a measurement defined from the plane on the right to the right-hand hole, shown by the 11.18 reference dimension. The plane's location is controlled by two constructed features, intersect lines, shown by the red circles.

The TolAnalyst study does not consider dimensions and tolerances applied to constructed features. A warning message appears, indicating incomplete tolerance chains.

For example, TolAnalyst does not consider the dimensions applied to the intersect line. The values 20, 50, and 60 do not change. TolAnalyst does consider the dimensions applied to the holes.
The TolAnalyst study considers dimensions and tolerances applied to the constructed features and holes. No warning messages appear.

The values 20, 50, and 60 change.

**Fixed and Floating Fastener Assemblies**

TolAnalyst can now consider the clearances resulting from fixed and floating fastener assemblies when it computes the worst case tolerance conditions.

When you locate and constrain parts in assemblies using fasteners, the new **Float fasteners and pins** option uses the clearances between the holes and fasteners to increase the worst-case minimum and maximum result. Each part can move in an amount equal to the radial distance between the hole and fastener.

For fixed fastener assemblies, float applies to the part with clearance holes only. For floating fastener assemblies, float applies to both parts. You can also apply float to parts that are located and constrained using hole-pin mating schemes.

**When to Consider Using Fastener Float**

- If the sole function of the clearance holes is to provide room for the fasteners, and the clearances are used to aid and provide adjustment to the assembly, using fastener float is generally **not** recommended.
- If the clearance holes are also used to locate the parts, and you need to know the adverse effects the clearances allow, using fastener float **is** recommended.

**Using Float in a Fixed Fastener Assembly**

This example illustrates the effects fastener float has on a measurement with parts constrained by fixed fastener assemblies.
The measurement to evaluate is the minimum and maximum distance between the inner faces of the axle supports.

The assembly includes axle supports that are fastened to the top plate using 10 mm bolts.

The top plate and axle supports have these dimensions and tolerances.

**Fixed Fastener Assembly Without Float**

To evaluate the worst case scenario without considering fastener float:

1. **Open** TolAnalyst\Fixed\Castor.sldasm.

2. In the DimXpertManager, right-click **Study1** and select **Edit Feature**.
   
   In the **Result** PropertyManager, under **Analysis Parameters**, note that **Float fasteners and pins** is cleared. Float is not considered. Under **Analysis Summary**, the **Min** is 48.5 and the **Max** is 51.5, for a total range of 3mm.
To achieve the worst case minimum, given the top plate's threaded hole diameter 0.5 position tolerance, TolAnalyst simulates the 105 basic dimension between the threaded holes at 104.5.

For the axle supports, when TolAnalyst simulates the clearance holes at their LMC size of 11.5, the resultant position tolerance is 1.0, enabling the 27.5 basic dimension from datum B to the holes to be calculated at 28.

Assembling the parts with the fastener float option cleared, TolAnalyst aligns the clearance holes in the axle supports concentrically with the threaded holes in the top plate, resulting in a worst case minimum of 48.5.

**Fixed Fastener Assembly With Float**

To evaluate the worst case scenario considering fastener float:

- In the PropertyManager, select **Float fasteners and pins** under **Analysis Parameters**. The worst case minimum decreases to 47 while the worst case maximum increases to 53. The total range of 6mm is double the range of that without fastener float.
To achieve the worst case minimum result, TolAnalyst calculates the parts as described in the procedure where float is not considered. See Fixed Fastener Assembly Without Float on page 168. When the parts are assembled, the axle supports are pushed inward (as shown by the red arrows below) until the clearance holes make contact with the bolts, resulting in a minimum worst case of 47.

Using Float in a Floating Fastener Assembly
This example illustrates the effects fastener float has on a measurement with parts constrained by floating fastener assemblies.

The assembly includes axle supports fastened to the top plate using 10 mm bolts. The measurement to evaluate is the minimum and maximum distance between the inner faces of the axle supports.
The top plate and axle supports have these dimensions and tolerances.

Floating Fastener Assembly Without Float

To evaluate the worst case scenario without considering fastener float:

1. **Open** TolAnalyst\Floating\Castor.sldasm.

2. In the DimXpertManager, right-click **Study1** and select **Edit Feature**.
   In the **Result** PropertyManager, under **Analysis Parameters**, note that **Float fasteners and pins** is cleared. Float is not considered. Under **Analysis Summary**, the **Min** is 48 and the **Max** is 52, for a total range of 4mm.
To achieve the worst case minimum, TolAnalyst calculates the top plates clearance holes at their LMC size of 11, resulting in a position tolerance of 1. TolAnalyst can then simulate the 105 basic dimension between the holes at 104.

For the axle supports, when TolAnalyst calculates the clearance holes at their LMC size of 11, the resultant position tolerance is 1.0, enabling the 27.5 basic dimension from datum B to the holes to be calculated at 28.

Assembling the parts with the fastener float option cleared, TolAnalyst aligns the clearance holes in the axle supports concentrically with the threaded holes in the top plate, resulting in a worst case minimum of 48.

**Floating Fastener Assembly with Float**

To evaluate the worst case scenario considering fastener float:

- In the PropertyManager, select **Float fasteners and pins** under **Analysis Parameters**. The worst case minimum decreases to 46 while the worst case maximum increases to 54. The total range of 8mm is double the range for when TolAnalyst did not consider fastener float.
To achieve the worst case minimum result, TolAnalyst simulates the parts as described in the procedure where float is not considered. See *Floating Fastener Assembly Without Float* on page 171. When the parts are assembled, the axle supports are pushed up against the inside faces of the top plate's clearance holes, and to the outside faces of the axle supports' clearance holes, resulting in a worst case minimum of 46.